525 XY Tension (Some Bearings Not Touching)

My 3/4" conduit (from Lowes) is all 23.32mm. I printed the parts myself in PLA. I just recently migrated to the new 525 middle and z assemblies. I also took the opportunity to upgrade from a 2’x3’ rail setup to 4’x4’. All of this so I can cut out an iTopie frame. I am having a hard time getting the middle assembly square. First off the rails want to spread apart as they come out of the back of the middle assembly. To fix that should I flex them square and then tighten tension bolt b?

I am also not able to get the lower bearings by tension bolt A to ever touch the conduit (on X and Y), even if I crank down tension bolt A until that bearing can’t even move anymore. I’ve also messed with tightening down tension bolt B, but no change on that outer lower bearing by tension bolt A (on both X and Y). I know I will probably need to print out a new XY, but wanted to see if I tightened it down enough if I could get contact (see attached image).

It seemed that everything is pretty close and my initial cuts were fine, as long as they are a small area. I made sure to square up X/Y rollers, as the Y is always 1/4-1/2" off before I power up RAMPS. I can draw a 40x40mm, 20x20mm, and 20mm circle all starting at the same starting point and they measure perfect (using pen attachment). Where I started to see a problem and I was wondering if it has to do with the play is cutting out the part you see in the attached Estlcam shot. Each time the dw660 gets to about that area circled in green, the Y axis seems to stutter for a step. I don’t see this when moving it through manually with the LCD 10mm at a time in just the Y axis. So I was wondering if close to the middle of the build area if that play allows it to pop/stick a little. I also attached the gcode for the cut I am attempting. If you try it in the air, even without cutting I can reproduce the glitch. I don’t have anything else to try it on to see if it is just the gcode. I’ve had some odd behavior with Estlcam and holding tabs at times.

My belts all have good equal tension and the pulley set screws have blue loctite and are not slipping. I have no Z slip/sticking as I had experienced that early on, but have that resolved.

I ordered the steppers off of ebay, but they have been working fine. They currently have 0.7v set on the drivers, and I can use the LCD to move them from one side to the other using 10mm step, but cranking 400 at a time and it just slides over without ever stuttering.

I do not have any of the newer parts for rollers or corners. I’m using all of the other parts from before the new corner designs.

Any advise would be greatly appreciated!

VerticalRight.gcode_.zip (1.07 KB)

So non of this is my hardware or electronics?

The bearings not touching with the new parts does not sound right at all. You did print the 23.5mm parts right, they all have a “C” on them somewhere?

23.32mm also sounds a bit low, are you sure they aren’t kind of ovals? If you rotate them is it wider?

Besides all that the last part is to actually square up your axis before you start a cut. This machine has very long axis usually when you drag the head around it will make it lopsided. Once you get the bit where you want to start measure both sides of each axis and make sure they are equal distances from the corner blocks to the roller assemblies.

So your movement issues are also a another issue all together. Please use repetier to try your motion control instead of the LCD and see if that fixes your movement issues. Manual moves form the LCD are trouble some. Much easier just to move it by hand. if you want to test movement use a gcode file I have test scripts and test files posted. Manual moves don’t really tell much.

  1. Electronics and parts. I printed the parts myself and had and Arduino + ramps board already. I’m close to ordering a new ramps board from you, just as a test. I bought the drivers from you to replace the cheap knockoff ones that my ramps board came with. I have these steppers: NEMA 17 76oz/in

I had been using this setup with with the 2’x3’ frame plus old and new middle assembly to 3d print and it had been incredibly accurate. I’ve only recently started to try to mill the large iTopie frame on this new 4’x4’ frame and noticed these new issues.

  1. Yeah, it’s really odd. The conduit is all 23.32-23.47mm range. It’s not perfectly round, but it’s not 23.5mm. I measured the conduit from my old frame that was working great and it also was all < 23.5mm. I might go take my caliper to The Home Depot and see if their conduit is closer to size.

I printed out the new middle/z assembly parts right after you published them, but I think before the different sizes were available. Mine all have the letter “c” on them. Yes, just confirmed from the files I generated gcode for C-XY, C-XYZ, and so on. They are the only files with a letter- prefix.

I might try reprinting one of the XY parts to see. I recently moved over to Simplify3D and maybe it will do a better job slicing than Cura did (printed on a Printrbot Simple Metal). I’m use to PLA shrinking if anything with bolt holes and such (also don’t have a heated bed), so for this to be larger is odd. It printed the tension bolt b area on the bed and worked it’s way up. Should I try printing this flipped vertically?

TROUBLESHOOTING UPDATE (my shudder/pop issues is related to electronics or gcode):
Okay, so I’m ignoring the LCD movement. I had read your advice about squaring up the rollers after manually moving and that fixes it so I can mill/draw perfect squares 20mm to 40mm and circles.

I just now took the entire middle assembly apart, reassembled and the problem persists. So I took all of the belts off. From my SD card I ran the gcode I attached to the original post and held my fingers loosely around one of the x and one of the y pulleys. It studders. So I tried the same cut. Leads me to think it is either the gcode or more likely it’s the electronics. I am going to double check my driver voltage.

I took a small video of it in action. You can see it shudder as it moves down the Y axis (at 10s mark) and then again as it’s turning to do the lower portion of the cut it shudders again (at 22s mark). It just jumps back a little in the opposite direction and then continues on. Sometimes it will mess up the cut and then go off into oblivion. Is this thermal shutdown that I’ve read about where there is a tiny delay? I’ll try the old clip on push fan to see if that makes a difference and double check my driver voltage next.

Video of Shudder Issue
Also, I use to use this cooler for my RAMPS board with a fan I bought from you. ramps 1.4 fan clip mount

As part of the wiring cleanup on this new frame I moved to this enclosure with 2 40mm fans I bought from you and have them pulling air out of the case (printed 50mm to 40mm adapters). new ramps enclosure

I am starting to wonder if my previous open with a fan blowing air directly onto the drivers was a better setup and if I’m getting overheating on long x/y operations possibly.

I’m going to setup a test cut that makes 900mm X and then 900mm Y line, then a diagonal cut to the opposite corner. That should isolate things a bit more. If it is overheating then it should be easily reproducible.

Sorry, I know you are really busy answering everyones questions. Thank you for this awesome machine. I’ve used the form and found answers to all of the other issues I ran into, this seems to be the last issue I have, but I couldn’t find anyone having this same issue. I really appreciate your time and this project!

Okay, I Just saw the picture of your roller. That doesn’t look even close. I would say start with printing a large calibration piece check all dimensions. I like to print 100mm in each direction to really check. I had made a test piece at one point but can find it right now maybe I’ll make a new one.

Lets start with that check the printer calibration.

I am printing this out now, but already I can measure it and tell that it’s right on overall width of 100mm. I scaled it up by 2.5x. Will let it finish and measure the other measurements. Thanks for the help!

Here is the calibration part I printed on my Printrbot Simple Metal. Another Calibration Square

I scaled it up 2.5x and after printing I measured and it was within 0.15m off all expected measurements.

I am working on the stepper stutter issue currently. No belts connected. I will print out a new C-XY part once I get that figured out. I think right now the stutter issue is the one actually causing me problems.

Try different g code, it might not be a hardware problem at all.

It is studdering without belts?

Yes, without belts. I’ve tried several different gcodes that move the steppers from full width/height diagonally. I haven’t tried them isolated just X and Y.

This might be a dumb, question but I have the vref set to 0.98 for X/Y. My motors are 1.4a, but now I’m wondering if I calculated that incorrectly. Are these really 11v?

It might also be interesting (assuming you are using Repetier or something like that) to turn off the settings where it sends updates to the LCD screen you have. I found that with Repetier Server it was causing the gcode parsing to occasionally miss steps or move in the wrong direction. The symptoms are similar to your stuttering issue. (Root cause on mine seems to be that Marlin doesn’t parse out the updates to the LCD quite properly for special characters.) Turning it off seems to resolve the issue for me.

John, I’m using Repetier-Host. Where is the setting located that you are talking about? I will give that a try!

Try backing the vref down to .7 then work your way up from there.

Still exhibits the issue at .7. I took it as far as .4 and it isn’t as powerful, but you can still fill it. I tried in Repetier and it almost seemed worse if that is possible.

I have new/different steppers and the same electronics for the iTopie build. I might try this all using those as a test. I’ve always just used the LCD and sd card for all of my 3d printing and have many hours of prints that worked out just fine.

under printer settings, “send ETA to printer.” while CNC, you can also turn off the “check bed temperature…” but it was the other one that caused issues in repetier-server. I assume you’ve also looked at the log window in repetier to see if it has any kind of errors as it’s running the gcode?

John: I will give that a try. I’m new to using Repetier, so not I didn’t look at the log window. I will watch it. It seemed to stutter much more using Repetier on my first attempt.

General Update: I threw on some new stepper motors (completely differnt). They still exhibited the stutter. So I installed Estlcam on a new Windows laptop and regenerated the cut path you see attached. It is set to cut 19.25mm.

Could someone do me a favor? Could you load up the attached Test1.gcode (it’s in the zip file and the only file in the attached zip file). Just raise your Z above cutting height and just run it without the rotary tool turned on. The tool will start where you see in the screenshot and actually starts cutting a few inches to the right of home there. Then as it moves left it will make that turn and start cutting that diagonal cut. Around the area in the green circle is where my stepper stutters or jumps back just a little and then continues on.

You can easily see this in the air without doing any actual cutting on the very first pass. Would someone mind running this for me to see if it stutters for you too on that diagonal anywhere, then I know this is a gcode issue. If not I am going to replace my arduino, ramps, lcd, and drivers with new extras I already have.

Thank you for all of the suggestions and help!

Test1.gcode_.zip (1021 Bytes)

i’ll run it tonight if someone else hasn’t replied, however… I just loaded it up into Repetier host and the travel moves look fine. I don’t think it’s the gcode.

It’s in the gcode. My machine is identical in the small stutter steps.

John, thank you so much for trying that. Now that I slow down the preview in Estlcam I can see the stutter in the preview also. Sorry I wasted your time to test that out. I will email Christian about the Estlcam issue. Before diving in to find the issue I noticed this issue when it would do a miss cut early on, but then eventually get back on path.

Ryan, I will print out a new C-XY and measure/compare it to the STL file.

Thank you for all of the help!

You can probably find the issue in the gcode and edit it out… And then get back to printing.

The problem is now I realize an issue I had a few days ago. I was doing a cut (not this one) with holding tabs. First time I had used holding tabs. It would do most of the cut fine and then go crazy and just start cutting where it shouldn’t be cutting. The fix for that was to manually tell it where to start the cut (not home, but where to lead into the cut). Then it made the entire cut just fine. This is all in this one DXF file so maybe I’ve uncovered a bug.