Advice for new build

Hi from Greece I am assembling my new LR2 and a need some guidance!!

  1. I will use Ryan board Sds pro 1.2 and TFT 35 v3 is there any case that i can print for both of them?

  2. I will use nema 17 92oz

  • Engine type: bipolar
  • Step angle: 1.8 deg.
  • Holding torque: 65 Ncm (92 oz).
  • Current/phase: 2.1 A.
  • Voltage: 3.36 V.
  • Resistance/phase: 1.6 ohms.
  • Inductivity: 3mH ± 20% (1KHz)
    do i need to adjust the voltage at 2209 drivers?
  1. I have both 12v and 24v 6A power supply from other projects which is better to use?

That is fine by the firmware. M906, IIRC. It should be set for a good starting place. But you could probably bump it up if you pay attention to the temps of your motors. You want to stay below 50C.

24V is better. It doesn’t make any difference at slow speeds, but you will get more torque at higher speeds. I doubt you will notice a difference.

Jeff, I’m just want to be clear, do you want to watch the motor temp or the stepper driver temp as you adjust the current up?

The motors. The stepper drivers can overheat, but that is usually at a higher limit. If your stepper drivers ever overheat, add a fan and they should be fine.

1 Like

Thanks Jeff for the reply.
Now i am at final steps before powering up my LR and of course i have more questions!!! I have purchased both sdk pro1.2 and tft35 from Ryan I want firmware with endstops do i need to but firmware inside and how? or the boards are all ready pre programmed?

They come from Ryan preprogrammed.

Jeff i did plug the power to my board and stuck at a screen that has two modes marlin mode or touch mode but I can select any of them!! When i remove sd card and power up i get black screen. Also tried repietier but i can’t connect!!! What i do wrong?? I also haven’t connect the limit switches for endstops I don’t know if that’s the problem.

There are two independent processors running. The one in the screen and the one in the skr.

The screen looks like maybe the encoder button is stuck pressed down. Try pulling it out of removing it from the case. The knob presses down for a button press.

On the skr, what os are you using? Make sure you don’t have repetier server installed. The baud rate should be 250k and make sure you get the right port. If that doesn’t work, show me as much detail as you can. “I can’t connect” isn’t enough detail for be to help.

I have removed the knob and the screen from case but no response at all.
I even try update tft35 firmware but stuck at 16% to 18% I don’t know why!!
At my repetier windows installation I didn’t install repetier server and baud rate is at 250k.
With repetier I should connect to the srk pro 1.2 regardless if the tft is setup correctly?

Please check if i have any faults at connections

Someone else had a similar issue and it was because the knob was always pushed. I don’t remember why or what fixed it.

Yes. You can disconnect the tft screen completely until you have the skr worked out. It would be nice if it was working to sort of inspect the skr from both sides. But it isn’t necessary at all.

AFAICT, it looks right and it is getting power, so it’s probably right. Can you try leaving the black cable in, but removing the gray ones?

Thanks Jeff i will try connect without the tft and I will get back with update!!

Finally the screen worked I had the grey cable setup wrong!!!
Now new problem…motors are not spinning and just making effort for turning.
I haven’t used Ryan kit motors (my mistake) but bought from Amazon.

The connection colours are
Black(A+), Green (A-), Red(B+), Blue(B-)


  • Motor Type: Bipolar Stepper
  • Step Angle: 1.8 deg.
  • Holding Torque: 65Ncm(
  • Rated Current/phase: 2.1A
  • Phase Resistance: 1.6ohms
  • Inductance: 3mH+/-20%(1KHz)

Is it possible to have the motor wiring wrong or it might need more power?

Motors are pretty dumb. They don’t have much to figure out about them. I would not trust the colors, but they need to be wired AABB. You can tell if two wires are on the same coil with a fun magic trick. Disconnect the belts and spin the shaft with everything unplugged. Then connect two of the motor wires. If they are part of a coil, turning the motor shaft will be harder. Significantly harder. Once you find one coil, the other two wires are the other coil.

Once they are wired AABB, every combination of wiring will result in the motor either moving one way, or the other. If you wire it BBAA, it will just be reversed.

There are some other things that could be wrong, and are honestly more likely.

  1. The power needs to be going to the terminals marked MOTOR.
  2. The jumpers need to be set for the tmc 2209 drivers.
1 Like

And check for the connectors on the SKR board, they should really be JST connectors as the black ones that come with most motors are not a tight fit…I had one a bit loose and was doing funny things too !!!


Hi, finally i got it all work with the endstops and draw the crown!! Thanks for your help. Now two more questions.

  1. Every time i power up my LR the coordinates are X (0) Y (0) but Z is 200 is that normal?
  2. At the LCD when I push home button it reaches the endstops as it should do and stops but when I push a button next to it a house with a Z in it. Only the left motor of z axis start to rise and I need to power it off.
    Any suggestions??

Interesting. That may be related to the dual endstop homing upwards. I hadn’t thought of that.

Sounds like something is wrong with the endstop wiring. Can you confirm the endstops are right with M119?

First photo when LR is at home and second away from the Endstops.
Also as I said before when i power up the z is at 200,0
What I have made wrong?

My z-axes also starts at 200. I am also using the dual endstop firmware. I am currently only drawing crowns, not yet in production, so don’t if it is normal.