All axis moving slow

I cannot grasp this one. So I have feed rate at 1000 mm/min, plunge rate at 75mm/min. The machine cuts excellent and moves smooth when cutting. It also runs fast while carving. The problem I cannot figure out is why does it take the machine so long to move to certain points on the carve to start cutting? Is there any way to speed this up? I have a lowrider2 3’x5’

What CAM are you using? Some expect a G0 to go at max speed, but in Marlin, it uses the last commanded speed. In Estlcam, you need to tell it to set the speed on every line, so the G0 have speeds too.

1 Like

Well I design in Easel then for the carve I used Repetier-host

I lied I am running feed rate of 750 mm/min. Here are the first 35 lines of the code. So line 4 where F is 228.6, does this need to change?

M3 S9000
G1 Z3.810 F228.6
G0 X38.053 Y85.362
G1 Z-0.500 F75.0
G1 X37.973 Y85.166 F750.0
G1 X38.168 Y85.161 F750.0
G1 X38.053 Y85.362 F750.0
G1 X39.724 Y84.626 F750.0
G1 X38.794 Y85.348 F750.0
G1 X38.467 Y85.913 F750.0
G1 X38.149 Y87.038 F750.0
G1 X38.213 Y89.228 F750.0
G1 X38.794 Y94.018 F750.0
G1 X37.949 Y93.432 F750.0
G1 X37.079 Y93.298 F750.0
G1 X36.128 Y93.604 F750.0
G1 X35.830 Y93.798 F750.0
G1 X37.669 Y87.632 F750.0
G1 X37.685 Y86.141 F750.0
G1 X37.226 Y85.018 F750.0
G1 X36.863 Y84.558 F750.0
G1 X38.474 Y84.519 F750.0
G1 X39.724 Y84.626 F750.0
G1 X38.521 Y83.249 F750.0
G1 X41.763 Y83.527 F750.0
G1 X42.163 Y83.662 F750.0
G1 X42.410 Y83.862 F750.0
G1 X42.619 Y84.399 F750.0
G1 X42.578 Y84.683 F750.0
G1 X42.432 Y84.951 F750.0
G1 X42.139 Y85.199 F750.0
G1 X41.591 Y85.412 F750.0
G1 X40.398 Y85.702 F750.0

No, you need a speed command on line 5.

As Jeff said, the G0 is using the last command speed (line 4’s F228.6).

Here is an example snippet from one of my files, you can see all G0/G1’s have a speed defined:

G1 X88.315 Y155.239 Z-1.750 F600.0
G1 X84.140 Y155.239 Z-1.750 F600.0
G0 X84.140 Y155.239 F1200.0
G0 Z4.000 F480
G0 X85.555 Y153.824 F1200.0
G0 Z4.000 F480
G1 X85.555 Y153.824 Z-3.500 F180.0
G1 X85.555 Y98.362 Z-3.500 F600.0


So line 3 and 10 I would add the feed rate that I would want?

G1 X41.631 Y84.152 F750.0
G1 Z3.810 F75.0
G0 X38.006 Y92.798
G1 Z-0.500 F75.0
G1 X36.957 Y92.675 F750.0
G1 X36.815 Y92.716 F750.0
G1 X37.655 Y89.900 F750.0
G1 X38.006 Y92.798 F750.0
G1 Z3.810 F75.0
G0 X27.744 Y94.149
G1 Z-0.500 F75.0

Correct, you would define a rapid feed rate that is meant to be moving in the air (tool not cutting anything).

I haven’t used Easel, but is there perhaps a setting or post processing that can define those G0’s for you? Otherwise you would have to manually edit your GCODE file each time to add them.

I think that is the downside to using Easel. It does not enter it for you. I will have to edit it in Repitier-host unless I can figure something else out. Thank you for the help!!!

1 Like

You can change the firmware to fix this too. You can set a G0 speed and then recompile it. But it would be easier is easel did that for you. Bummer.

Is it complex or rather easy? Any know how on how to do this?

So come to find out…. Repetier Host has a flow rate button that can toggle the speed of the machine when not cutting. I increased it to 120% and it’s moving faster now. No more sloth action!! Thanks for the help!