Arduino Mega + RAMPS - 1.6

Sorry if I created a topic not there, I know English very poorly.

Maybe someone has a marlin assembly on this board.
Could you share the firmware.
The motors do not work for me, from the computer and from the screen.
I already tried everything, there is simply no power on it.
The board is connected via a 12 volt power supply.
A4988 drivers.
2004a screen.
I connected the board strictly according to the instructions.
Installed firmware - MPCNC_Ramps_T8_16T_LCD_32step.
Huge request to treat with understanding, this is my first project in life.

Unfortunately those drivers and screen are different than my recommended ones that the firmware is made for. You will need to edit the firmware and change them.

Could I ask you to help me?

In my city there is nothing more for sale from other motherboards.

Or a link where I could read.

 

You can try taking a look at my configuration, which is for a Ramps1.4 w/ A4988s. BUT, mine is also configured for dual endstops, so be aware of that. You should also look through the boards.h file to verify the value you should be using for MOTHERBOARD.

It would ultimately be easiest to reconfigure from MPCNC_Ramps_T8_16T_LCD_32. The primary changes you’d be looking at are:

Double-check for a Ramps1.6 MOTHERBOARD value in boards.h
?_DRIVER_TYPE settings should be A4988
DEFAULT_AXIS_STEPS_PER_UNIT values should all be halved (you’re maxed at 16 microsteps, not 32)

For your LCD, find and change to the following (they are scattered through the config file):

// #define SHOW_CUSTOM_BOOTSCREEN

#define REPRAP_DISCOUNT_SMART_CONTROLLER

//#define REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER

If you can’t move the steppers from the computer there’s something basic wrong, the problems with having the wrong drivers and the wrong screen shouldn’t affect that. Please show us pictures of your board with everything connected to verify the power is correct. Also show us a screenshot of Device Manager showing the COM ports and the Repetier-Host screen with the printer setup displayed. R-H should be set to the same COM port and at 250000 bps.