Arduino not showing up as an available serial port

I have the kit and am just now getting the Arduino / Ramps up and running. However, when I connect it to my computer it doesn’t show up as an available serial port in Repetier or the Arduino IDE. I have a Arduino UNO on hand and when I connect it I can see the USB modem1421 in both Repetier and the Arduino IDE. When I power up the mega/ramps I get two flashes on the green LED next to the 1K resistor on the ramps and there is a red led lit up on the mega and that it all.

EDIT: I removed the ramps board from the mega and just connected it via usb and it powers up but still doesn’t show up as a com port. It has the ON and L led’s lit up and that is all.

Any help is much appreciated.


You need to change the baud rate in the firmware by half I believe. I am not positive of the number. I don’t have a mac, and there have only been 1 or 2 mac users.

Try this

Nope, the Mega was toast. I overnighted a new one in from Amazon $17.00 (awesome) plugged it in and it works. Tried the one from the kit on a PC this AM and same result.