Arduino + RAMPS=failure


I’m nearing completion of my MPCNC, but I’m having trouble with the RAMPS board. I flashed the marlin FW onto the arduino just fine, but nothing works once I attach the RAMPS board. Without the RAMPS installed, I can connect with Repetier host and send commands to the boards. With RAMPS installed, Repetier still connects, but all I get are timeouts. Also, I cannot re-flash the board with RAMPS installed, but can with the RAMPS disconnected.

W/O RAMPS, I get the following at the end of the log:

21:26:29.196 : echo:Material heatup parameters:
21:26:29.198 : echo: M145 S0 H196 B62 F0
21:26:29.198 : M145 S1 H240 B110 F0
21:26:29.198 : echo:PID settings:
21:26:29.202 : echo: M301 P17.98 I0.98 D83.62
21:26:34.280 : echo:SD init fail
21:26:34.309 : FIRMWARE_NAME:Marlin 1.1.0-1 (Github) SOURCE_CODE_URL: PROTOCOL_VERSION:1.0 MACHINE_TYPE:MPCNC EXTRUDER_COUNT:1 UUID:cede2a2f-41a2-4748-9b12-c55c62f367ff
21:26:34.350 : X:0.00 Y:0.00 Z:0.00 E:0.00 Count X:0 Y:0 Z:0
21:26:34.354 : echo:DEBUG:INFO,ERRORS
21:26:34.358 : echo:Active Extruder: 0
21:26:34.358 : Begin file list
21:26:34.359 : End file list
21:26:34.362 : echo:DEBUG:INFO,ERRORS
21:26:34.362 : echo:Active Extruder: 0

With RAMPS installed, the log ends at SD init failure, then I start getting timeouts about 30s later:

21:59:08.970 : M145 S1 H240 B110 F0
21:59:08.970 : echo:PID settings:
21:59:08.971 : echo: M301 P17.98 I0.98 D83.62
21:59:14.045 : echo:SD init fail
21:59:52.148 : Communication timeout - reset send buffer block

Communications speed is set to 250000.

I have tried this without the motor controllers installed. I have confirmed 12V on the RAMPS 5A input (far right on the connector). I have confirmed 5V and 3.3V rails with only the 12V connected (no USB,
regulator is working).

Any other ideas as to what might be wrong, or the next step in troubleshooting? The RAMPS board is pretty simple. Is it possible I’m the bad-luck guy and got a defective RAMPS board?



See if both diodes are facing the right way, and none of the mosfet are touching. A picture could really speed this up. Although, there are a ton of crappy ones out there. I just have 50% of my last orders ramps mosfets fail, all kinds of goofy things go wrong. The biggest one is dry/missing solder under the black pin bars. I have to check everything because I have seen probably all failure modes.

My newest firmware, which one?

Photos attached. I looked at both boards under an inspection scope. The solder on the RAMPS board leaves a lot to be desired, but I didn’t see anything terrible, such as an unsoldered pin or a bridge anywhere.



Oops, forgot to to mention that it is your latest firmware.

I think I found the problem. I found a review on Amazon that mentioned a board layout error on one of the boards purchased there. The error was that the Arduino RX pin was shorted to the 12V rail on the RAMPS board, which would explain the communication issues I was having. I checked and, sure enough, my board had the same short. I bought it from Nevada Robotics am returning it. I’ve ordered a new one from REPRAPGURU (the author of the listing) and will update things in a week or so, after I’ve received the new board.

The review is here:

Thanks for the help and the design. I’m looking forward to getting it working.


The most random problems with these things. Fingers crossed for you.

Board from REPRAPGURU worked great. You definitely need to watch the vendors on Amazon. That said, the return policy is nice and I got a working board in the end, though the hours of troubleshooting weren’t all that great. Hopefully this post will help someone avoid similar problems.