Arduino upload error

I try to load B16_32-LCD-112515 and I get an error message that states

exit status 1
Using typedef-name ‘fpos_t’ after ‘struct’

Any thoughts?

I could get the marlin_16_32_090615_therm one to load but I get a maxtemp error as soon as I connect to repetier host.

Mac or pc, what version of arduino? Did you load the LCD library?

The "therm"file is for a different value resistor.

PC… to be totally honest, I have no idea what I’m doing.

I’m not sure what you mean by version. This is the first time I’ve used an arduino.

And I’m not using an lcd screen. But you have a note by that file designating it the one to use if you don’t have a screen.

Shold I be using a different file?

I’ve added the resistor (100k) with a 2 pin connector.

Adjusted stepper voltage (.4 for z and .7 for x and y)

I start the Arduino IDE and plug my ramps stack in.

Unzip the file you provide and pick the arduino file I want and click upload.

This is my arduino…

And I’m running Arduino IDE 1.81 on a Windows 10 PC.

Try the old version of the Arduino software… Ah ARDUINO 1.0.6.

I had that problem a few months back and if I remember that solved that problem for me…


Worked like a charm! Thanks Richard.