Awakening an MPCNC that's been sitting 2 years

Hi Everyone,

So two years ago I built an MPCNC and got as far as the first cut and then got distracted by another project and left it to sit. I’m back at it and looking for some advice.

  1. Is there anything I should do with my Ramps 1.4 board? I noticed a thread that mentioned the resistor is no longer needed, but I assume this would require flashing new firmware? I also noticed there is some new auto squaring dual end stop stuff going on. What do I need to know there?
  2. I noticed that many of the parts are cracked. Specifically the C-Z-Lower, C-Z Motor, C-XYZ, C-Nutlock, and C-XYZ. I'm going to reprint those and rebuild.
  3. I managed to get Repitier connected and try some movement, but for some reason both the X and Y axis go the same direction no matter if I press the button to go in the negative or positive direction. Any ideas why this might be the case?
Thanks, Ben.

welcome back.

1-Nope if it worked before it should still work now. You have the option of more accuracy with dual endstops but you are not currently wired for it. There is a page that explains exactly what it is linked in a few places.

2-Full rebuild, make sure to not go so tight, the large bolts (non-tension bolts) 5.5NM torque.

3-It worked before? I am not sure what could cause that, a typical problem would be positive only movements. But not controls going the wrong direction.

1 Like

Thanks for the reply. Good to be back. I’m at work but I do think the issue I’m having is that no matter what direction I try to manually move in, it only goes in one direction. I press either the positive direction or negative and it only goes positive. This is occurring with both the X and Y

this looks like firmware see that endstops is signaled. such thing could happens when endstops defined as NC and is diconnected.
also check is your firmware has disabled “software endstops”

1 Like

Well Guffy… Turns out in a stroke of genius I did indeed disconnect my endstops thinking that it would eliminate some variables to get things going smoother. I forgot that they would be looked for and not be there. Looks like this will get me going again! Thanks!