Bad Rambo Board?

I just got my Lowrider 2 with a pre- flashed Rambo v1.4 finished
All works well excepted X1 stepper motor dos not work.
When I swop out the connection on the board the X1 works and X2 doesn’t.
I have replead all the wiring and connections between the stepper motor and board.

Dos anyone have a solution to my problem?

What firmware is flashed on it?

The stepper connections on the RAMBo are X, Y, Z, Z(in parallel), E0 E1.

If you have serial firmware, the E0 and E1 connections are not used, and will not be live.

If you have dual endstop firmware, you should not be using the second Z port. Actually, you should not be using the second Z port in any case the parallel connection there halves the motor current. You should be using the series wiring harness, which connects both motors to one plug at the RAMBo board.

1 Like

Thanks I will try that

Ryan doesn’t flash dual firmware for the low rider. Your second Z works because you have it worked in parallel (so each motor is getting half current, not good).

You can write the two X motors in series and the two Z motors in series (that is my recommendation).

Or you can flash the dual endstop firmware yourself. It is a community backed firmware, so keep that in mind. It may have issues (but it has been used before).

Hi jeffeb3

I have a lowrider 2 with Dual Endstop and I am using a (large) Rambo board I am trying to flash it with V1CNC Rambo Dual LR-2 no matter what I do I get this error message (Error compiling for board RAMBo.)
I am sending photos of all my settings that are in Arduino.

![Photo 1
![Photo 2
![Photo 3
![Photo 4
!Photo 5

Generally, a Compile error indicates a problem with the configuration setting within (or missing) source files, not a problem with the physical board. I know that the Marlin firmware won’t compile on the Arduino IDE running on Windows any longer since there are so many folders that the path gets too long. I’m not sure whether the same is true for Arduino IDE on MacOS (which I’m inferring from your screen shots), but I also see that Windows 10 Parallels icon.

It might be helpful if you could provide the error messages from that “Copy Error Messages” button. That may point to the specific directive that’s causing the compile failure.

(edited to clarify where the compiling problem shows up)

/Applications/ -dump-prefs -logger=machine -hardware /Applications/ -hardware /Users/davidsharp/Library/Arduino15/packages -tools /Applications/ -tools /Applications/ -tools /Users/davidsharp/Library/Arduino15/packages -built-in-libraries /Applications/ -libraries /Users/davidsharp/Documents/Arduino/libraries -fqbn=rambo:avr:rambo -vid-pid=0000_0000 -ide-version=10819 -build-path /var/folders/cf/hwmt1xqs4yv33_wsqb56_d040000gn/T/arduino_build_35455 -warnings=all -build-cache /var/folders/cf/hwmt1xqs4yv33_wsqb56_d040000gn/T/arduino_cache_804538 -prefs=build.warn_data_percentage=75 -verbose /Users/davidsharp/Desktop/V1 folder/V1CNC_Rambo_DualLR-2/Marlin/Marlin/Marlin.ino
/Applications/ -compile -logger=machine -hardware /Applications/ -hardware /Users/davidsharp/Library/Arduino15/packages -tools /Applications/ -tools /Applications/ -tools /Users/davidsharp/Library/Arduino15/packages -built-in-libraries /Applications/ -libraries /Users/davidsharp/Documents/Arduino/libraries -fqbn=rambo:avr:rambo -vid-pid=0000_0000 -ide-version=10819 -build-path /var/folders/cf/hwmt1xqs4yv33_wsqb56_d040000gn/T/arduino_build_35455 -warnings=all -build-cache /var/folders/cf/hwmt1xqs4yv33_wsqb56_d040000gn/T/arduino_cache_804538 -prefs=build.warn_data_percentage=75 -verbose /Users/davidsharp/Desktop/V1 folder/V1CNC_Rambo_DualLR-2/Marlin/Marlin/Marlin.ino
Using board ‘rambo’ from platform in folder: /Users/davidsharp/Library/Arduino15/packages/rambo/hardware/avr/1.0.0
Using core ‘arduino’ from platform in folder: /Applications/
Detecting libraries used…
/Applications/ -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega2560 -DF_CPU=16000000L -DARDUINO=10819 -DARDUINO_AVR_RAMBO -DARDUINO_ARCH_AVR -I/Applications/ -I/Users/davidsharp/Library/Arduino15/packages/rambo/hardware/avr/1.0.0/variants/rambo /var/folders/cf/hwmt1xqs4yv33_wsqb56_d040000gn/T/arduino_build_35455/sketch/Marlin.ino.cpp -o /dev/null
/Applications/ -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega2560 -DF_CPU=16000000L -DARDUINO=10819 -DARDUINO_AVR_RAMBO -DARDUINO_ARCH_AVR -I/Applications/ -I/Users/davidsharp/Library/Arduino15/packages/rambo/hardware/avr/1.0.0/variants/rambo /var/folders/cf/hwmt1xqs4yv33_wsqb56_d040000gn/T/arduino_build_35455/sketch/src/HAL/AVR/HAL.cpp -o /dev/null
/Applications/ -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega2560 -DF_CPU=16000000L -DARDUINO=10819 -DARDUINO_AVR_RAMBO -DARDUINO_ARCH_AVR -I/Applications/ -I/Users/davidsharp/Library/Arduino15/packages/rambo/hardware/avr/1.0.0/variants/rambo /var/folders/cf/hwmt1xqs4yv33_wsqb56_d040000gn/T/arduino_build_35455/sketch/src/HAL/AVR/HAL_SPI.cpp -o /dev/null
/Applications/ -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega2560 -DF_CPU=16000000L -DARDUINO=10819 -DARDUINO_AVR_RAMBO -DARDUINO_ARCH_AVR -I/Applications/ -I/Users/davidsharp/Library/Arduino15/packages/rambo/hardware/avr/1.0.0/variants/rambo /var/folders/cf/hwmt1xqs4yv33_wsqb56_d040000gn/T/arduino_build_35455/sketch/src/HAL/AVR/MarlinSerial.cpp -o /dev/null
/Applications/ -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega2560 -DF_CPU=16000000L -DARDUINO=10819 -DARDUINO_AVR_RAMBO -DARDUINO_ARCH_AVR -I/Applications/ -I/Users/davidsharp/Library/Arduino15/packages/rambo/hardware/avr/1.0.0/variants/rambo /var/folders/cf/hwmt1xqs4yv33_wsqb56_d040000gn/T/arduino_build_35455/sketch/src/HAL/AVR/Servo.cpp -o /dev/null
/Applications/ -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega2560 -DF_CPU=16000000L -DARDUINO=10819 -DARDUINO_AVR_RAMBO -DARDUINO_ARCH_AVR -I/Applications/ -I/Users/davidsharp/Library/Arduino15/packages/rambo/hardware/avr/1.0.0/variants/rambo /var/folders/cf/hwmt1xqs4yv33_wsqb56_d040000gn/T/arduino_build_35455/sketch/src/HAL/AVR/eeprom.cpp -o /dev/null
/Applications/ -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega2560 -DF_CPU=16000000L -DARDUINO=10819 -DARDUINO_AVR_RAMBO -DARDUINO_ARCH_AVR -I/Applications/ -I/Users/davidsharp/Library/Arduino15/packages/rambo/hardware/avr/1.0.0/variants/rambo /var/folders/cf/hwmt1xqs4yv33_wsqb56_d040000gn/T/arduino_build_35455/sketch/src/HAL/AVR/fast_pwm.cpp -o /dev/null
/Applications/ -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega2560 -DF_CPU=16000000L -DARDUINO=10819 -DARDUINO_AVR_RAMBO -DARDUINO_ARCH_AVR -I/Applications/ -I/Users/davidsharp/Library/Arduino15/packages/rambo/hardware/avr/1.0.0/variants/rambo /var/folders/cf/hwmt1xqs4yv33_wsqb56_d040000gn/T/arduino_build_35455/sketch/src/HAL/AVR/fastio.cpp -o /dev/null
/Applications/ -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega2560 -DF_CPU=16000000L -DARDUINO=10819 -DARDUINO_AVR_RAMBO -DARDUINO_ARCH_AVR -I/Applications/ -I/Users/davidsharp/Library/Arduino15/packages/rambo/hardware/avr/1.0.0/variants/rambo /var/folders/cf/hwmt1xqs4yv33_wsqb56_d040000gn/T/arduino_build_35455/sketch/src/HAL/AVR/u8g_com_HAL_AVR_sw_spi.cpp -o /dev/null
Alternatives for U8glib-HAL.h: []/Users/davidsharp/Desktop/V1 folder/V1CNC_Rambo_DualLR-2/Marlin/Marlin/src/HAL/AVR/u8g_com_HAL_AVR_sw_spi.cpp:65:10: fatal error: U8glib-HAL.h: No such file or directory

#include <U8glib-HAL.h>
→ candidates: []compilation terminated.

exit status 1
Error compiling for board RAMBo.

I know that the Marlin firmware won’t compile on Windows any longer

Marlin no longer compiles using the Arduino IDE. See PlatformIO for instructions on how to get the current version to compile and upload. Or you can avoid the whole compile by using XLoader to move the binary compiled by V1 directly to the board.


I have a Mac and I have tried that Platforml0 and I still get a error message so I will try XLoader and we’ll see how it works.

Oh, you are compiling on the Mac. I don’t know if it will compile using the Arduino IDE on the Mac, but I know the U8glb-0HAL.h library that it is complaining about at the end of your long error output is not included as part of the Arduino standard libraries. Back when Marlin did compile using the Arduino IDE, I had to add a similar library to my build environment before compiling was successful. So maybe if you add the U8glb-0HAL library, it will compile on the Mac. The way I remember it, Marlin failed compilation on Widows due to the length of command lines…a limit that likely would not exist on the Mac architecture.

I believe that XLoader is Windows only.

I don’t know about later versions, but I did compile 510 with the Arduino IDE for Linux. I changed to platformio after that. I did need the U8glib libraries downloaded separately. (You don’t need these if you remove support for the 12864 LCD controller.)

The only file I can fined is U8glib-HAL
Can you tell me where I can fined U8gil-OHAL

Not sure why I put the ‘0’ in there. It appears that U8glib-HAL is what you are looking for. This is only theory on my part based on the error. When I was using the Arduino IDE for Marlin, it was the U8glib library, as Dan indicated, that needed to be included.

I used XLoader on Windows on my Mac threw Parallel and I was able to flash the Rambo board,
it looks like all I have to do now is plug my wires in a different order on the board, when I get that done I will let you know how that worked out.Thanks for all your help I appreciate it very much.


Good work. I did not know xloader worked in parallels. That is definitely 100x easier than platformio.