Bad skr pro v1.2 board

So, I bought a kit and got it together. Everything seems to be going well except E1 doesn’t work. I’m using the individual wiring and end stops.

I tried swapping the drivers on the board but the problem still stays with E1. I swapped wiring between motors and it is still with E1. Is there any options that I have to trouble shoot further or any configuration issues that could lead to this problem?


Also looks like I accidentally posted this in the lowrider section… Not sure if I corrected that.

Trace the wiring on that axis. Sometimes crimps are bad (pinched insulation instead of conductors) or pins slip inside the connectors or extensions come undone where you can’t see them. .

By ‘swapping the wiring between motors’ do you mean swapping the wiring AND the motor between controller board outputs or just swapping the wiring? If the same motor is still on the E1 output it could be a faulty or a differently internally wired motor (not all nema17 motors have their coils going to the same pins in their wiring connectors… maybe you have an odd one?) you can check the coil pairs with a simple multimeter, the coil pairs should be next to each other at the controller board connector. A1-A2-B1-B2. Other than that it looks like a configuration issue but if it is a recent purchase from V1 then that is unlikely if it came pre-loaded.

Yeah I swapped motor and wiring. Problem followed e1. So when swapped the other motor worked correctly. I did buy everything from v1. I haven’t messed with firmware at all yet. I’ll try loading the firmware from the site here and see what happens. Not much too lose. It might be a couple days before I can get back out into the garage though.

Finally got a chance to load new firmware last night. That resolved it! Didn’t get a chance to go any further than that. Hopefully tonight. Thanks for all the responses!