BIGTREETECH SKR PRO V1.2 Control Board 32Bit+TMC2130+TFT35 V2.0

Hi Guys I have BIGTREETECH SKR PRO V1.2 Control Board 32Bit+TMC2130+TFT35 V2.0 components and was wondering if someone can point me in right direction to build the primo by letting me know which one to download on list below.

1.Firmware for the board

V1CNC_SkrPro_2209-2.0.7-src.zip13.2 MB

V1CNC_SkrPro_DualLR_2209-2.0.7-src.zip13.2 MB

V1CNC_SkrPro_Dual_2209-2.0.7-src.zip13.2 MB

2.Firmware for the display to get just the CNC

BIGTREE_TFT35_V3.0.26.x.bin180 KB

BIGTREE_TFT35_V3.0_E3.26.x.bin181 KB

The skr pro dual (not lr) is close, but it is for different drivers. You can either but tmc 2209 drivers or change the driver types to 2130 and recompile it using vscode and platformio.

1 Like

how about the display ? my current display version is

Firmware: TFT35_V2.0.26 Apr 11 2020

The tft firmware is for the v2_e3, which has a knob. But you can compile it for the v2 without the knob.

Thanks so so so much for you time and patience

1 Like

Hi Jeff were do I find this file

Do I also need 6 TMC drivers or I can do with 5 ?

I think just 5.

how about the were to find the



The tft firmware is for the v2_e3, which has a knob. But you can compile it for the v2 without the knob.

You pasted a picture from that repo, so I assumed you already knew the answer to that. We haven’t compiled it for your screen, but the release page you posted is where the code is.

I am having a field day with SKR boards I just cannot win
changed the TMC 2130

Printer is now online.

Reporting endstop status

echo:Unknown command: “M122”

None of the Stepper motors will move
Any help will me appreciated

Do you have power running to the motors on the new board?

I had to do these steps to revive the board

For clarification :

  1. Jumper BOOT0 Pin to 3.3V
  2. Get and FTDI Adapter,
  3. Download
  4. Make sure logic voltage switch on FTDI Adapter is 3.3v
  5. Connect to SKR Pro 1.1 as follows : Connect FTDI 3.3v and ground to SKR 3.3v (near UART CONNECTOR) and ground pins
  6. Connect FTDI TX to TFT Connector RX1 and FTDI RX to TFT Connector TX1 (For me the UART TX and RX Pins didnt work)
  7. Open Demonstrator GUI, select the correct com port click next. If error appears, check wires
  8. If OK, message will confirm connection Click Next again and and Next Again
  9. In the next screen click the … near the downoad to device section and select the .BIN file to upload.
  10. Click next and wait.
  11. When done, dont forget to remove the BOOT0 jumper.

FYI Marlin firmware does not contain the bootloader, you’ll need a copy of firmware which includes the bootloader.

Full Firmware including bootloader :


X Y Y2
Enabled false false false
Set current 600 600 600
RMS current 1049 1049 1049
MAX current 1479 1479 1479
Run current 18/31 18/31 18/31
Hold current 9/31 9/31 9/31
CS actual 0/31 0/31 0/31
PWM scale 0 0 0
vsense 0=.325 0=.325 0=.325
stealthChop false false false
msteps 256 256 256
tstep 0 0 0
PWM thresh.
OT prewarn false false false
off time 0 0 0
blank time 16 16 16
-end -3 -3 -3
-start 1 1 1
Stallguard thrs
stst * * *
Driver registers:
X 0x00:00:00:00 Bad response!
Y 0x00:00:00:00 Bad response!
Y2 0x00:00:00:00 Bad response!
Testing X connection… Error: All LOW
Testing Y connection… Error: All LOW
Testing Y2 connection… Error: All LOW

Phew !!! any one know what causes this Error ? I am using TMC 2130 V3.0

None of the stepper motors will still not move

Yes and still not movement

That is not dual endstops firmware. There should be 5 motors, not 3. Makes me wonder if your 2130 firmware made it on there.

That is saying it can’t talk over spi to the drivers. They are missing power, or they aren’t connected (are the jumpers right?). The firmware is configured for the wrong drivers. Or the drivers are soldered in standalone mode.

I ordered the TMC 2209 and hopefully they show up .Thanks