BIGTREETECH SKR V1.3 32 Bit + TMC5160 V1.2 + MKSTFT28 V4.0

Can someone please help me with what files I do for this set up . Moving away from TT Teaching firmware

BIGTREETECH SKR V1.3 32 Bit + TMC5160 V1.2 + MKSTFT28 V4.0

I managed to do the change in VS and loaded the bin file but all I get from doing the M122 is

m122
SENDING:M122
axis:pwm_scale/curr_scale/mech_load|flags|warncount
X X2 Y Y2 Z
Enabled false false false false false
Set current 900 900 900 900 900
RMS current 893 893 893 893 893
MAX current 1259 1259 1259 1259 1259
Run current 26/31 26/31 26/31 26/31 26/31
Hold current 20/31 20/31 20/31 20/31 20/31
Global scaler 130/256 130/256 130/256 130/256 130/256
CS actual 31/31 31/31 31/31 31/31 31/31
PWM scale 4294967295 4294967295 4294967295 4294967295 4294967295
stealthChop true true true true true
msteps 0 0 0 0 0
tstep 4294967295 4294967295 4294967295 4294967295 4294967295
PWM thresh.
[mm/s]
OT prewarn true true true true true
triggered
OTP false false false false false
off time 15 15 15 15 15
blank time 54 54 54 54 54
hysteresis
-end 12 12 12 12 12
-start 8 8 8 8 8
Stallguard thrs 0 0 0 0 0
uStep count 65535 65535 65535 65535 65535
DRVSTATUS X X2 Y Y2 Z
sg_result 1023 1023 1023 1023 1023
stallguard * * * * *
fsactive * * * * *
stst
olb * * * * *
ola * * * * *
s2gb * * * * *
s2ga * * * * *
otpw * * * * *
ot * * * * *
Driver registers:
X 0xFF:FF:FF:FF Bad response!
X2 0xFF:FF:FF:FF Bad response!
Y 0xFF:FF:FF:FF Bad response!
Y2 0xFF:FF:FF:FF Bad response!
Z 0xFF:FF:FF:FF Bad response!
Testing X connection… Error: All HIGH
Testing X2 connection… Error: All HIGH
Testing Y connection… Error: All HIGH
Testing Y2 connection… Error: All HIGH
Testing Z connection… Error: All HIGH

If the SKR 1.3 cannot communicate with the TMC5160s, please check this is uncommented in configuration_adv.h:

#define TMC_USE_SW_SPI

All high went away
but now all my stepper motors are moving crazy like
what is the different from Dual LR and Dual

#define X_DRIVER_TYPE TMC5160

#define Y_DRIVER_TYPE TMC5160

#define Z_DRIVER_TYPE TMC5160

#define X2_DRIVER_TYPE TMC5160

#define Y2_DRIVER_TYPE TMC5160

#define Z2_DRIVER_TYPE TMC5160

//#define Z3_DRIVER_TYPE TMC2209

//#define Z4_DRIVER_TYPE A4988

#define E0_DRIVER_TYPE TMC5160

#define E1_DRIVER_TYPE TMC5160

//#define E2_DRIVER_TYPE TMC2209

//#define E3_DRIVER_TYPE TMC2209

//#define E4_DRIVER_TYPE TMC2209

//#define E5_DRIVER_TYPE TMC2209

//#define E6_DRIVER_TYPE A4988

//#define E7_DRIVER_TYPE A4988

my configuration
MPCNC Stepper Motor count
x=1
y=2(dual)
z=2(dual)
same as Teching Tech

I did some troubleshooting this morning and this is now my stepper motor connection

X=X Y=Y(L) Z=Z (L) E0=Z2® E1=Y2®

Problem is when I move
X it more X and Z2®
how do I fix that

I uncomment #define X2_DRIVER_TYPE TMC5160 because I did not have two x but did not fix the problem

SENDING:M122
axis:pwm_scale/curr_scale/mech_load|flags|warncount
X Y Y2 Z
Enabled true false false false
Set current 900 900 900 900
RMS current 893 893 893 893
MAX current 1259 1259 1259 1259
Run current 26/31 26/31 26/31 26/31
Hold current 20/31 20/31 20/31 20/31
Global scaler 130/256 130/256 130/256 130/256
CS actual 20/31 20/31 20/31 20/31
PWM scale 19 19 19 19
vsense
stealthChop false false false false
msteps 32 32 32 32
tstep max max max max
PWM thresh.
[mm/s]
OT prewarn false false false false
triggered
OTP false false false false
off time 3 3 3 3
blank time 24 24 24 24
hysteresis
-end -1 -1 -1 -1
-start 1 1 1 1
Stallguard thrs 0 0 0 0
uStep count 260 4 4 4
DRVSTATUS X Y Y2 Z
sg_result 29 0 0 0
stallguard *
fsactive
stst
olb
ola
s2gb
s2ga
otpw
ot
Driver registers:
X 0x81:14:00:1D
Y 0x80:14:00:00
Y2 0x80:14:00:00
Z 0x80:14:00:00
Testing X connection… OK
Testing Y connection… OK
Testing Y2 connection… OK
Testing Z connection… OK

looks like its not seeing Z2 which is pluged into E0 .Help please

How do I achieve this Dual End Stops (EXTRUDERS=0)

If the firmware is set for EXTRUDERS=0 then E0 becomes X1 and E1 becomes Y2. (or LR would be E0=Y2 E1=Z2)

Phew!!! I deleted all the files and redownload the V1CNC_Skr1p3_DualLR_2209-2.0.7.2-src file now stepper motors are moving correctly but CNC is not homing (I have 5 end stop) 2 for y 2 for z and 1 for the x .Any help will be deeply appreciated

That should be right. What is the problem?

when I hit home all axis nothing happens do I need to enable anything in the firmware ?

Switches are configure for N/O when I was running Teaching Tech

So I went ahead and resoldered all my stop switch to N/C -So when I do the Auto home only one Z(L) moves up rather than down and the endstop one the Z® stops it. then the auto homing continues to do the X and then moves both Y.

On normal operation when I hit move z+ both up and z- both down .
only when I am trying to Auto home axis I get only Z(L) which is connect to drive Z not both.
Hope this helps to help me get this last thing fixed - Almost to the finish line. As always thanks a lot for your time and patience

I think it’s helpful to keep the overall homing sequence in mind when troubleshooting this issue. With the firmware and settings I use, the “default” homing cycle for a particular axis is:

  1. Move toward the endstop switch at a moderate speed until it triggers then stop.
  2. Move away from the endstop until the switch is no longer triggered.
  3. Move toward the endstop slowly until it triggers, then stop.
  4. Set the 0 position (or apply the known endstop offset) for the axis
  5. Move away from the endstop a set amount, which should be enough that the switch is no longer triggered (2-5 mm is common but depends on your machine).

In my experience, as long as you’re certain that the axis moves the right direction when not homing and the homing cycle direction (max or min) is set correctly , if the axis moves “backwards” when homing that means it thinks the endstop switch is already triggered so it is jumping to step 2 in the above list. Double-check your switch type (NO or NC) and that the firmware logic matches for that axis. Marlin does allow you to home each axis in a different direction.

Thanks Tom relative to your suggestion -It looks like there is something in the software that I need to change to accommodate homing Z to move towards the my Cnc bed then the end stops will engage as soon and it gets contact. In my case when I do home Z the it moves up rather than down and only moves one Z(L) instead of both .
what I am trying to achieve is both Z move down to engage the two end stops I have installed .This needs to be done before I can cut any thing on the lowrider 2 to ensure everthing is squared up .

which lines can double check the homing sequence in Marlin plus the switch type ? I have all my hardware configured for N/C. I can edit it to make me achieve my goal if you can let me know where in the firmware. All the motor move in the right directions except when homing ,things get this as I have mention in my previous post .
“On normal operation when I hit move z+ both up and z- both down .
only when I am trying to Auto home axis I get only Z(L) which is connect to drive Z not both.
Hope this helps to help me get this last thing fixed - Almost to the finish line.”

All I have done so far in my code is

V1CNC_Skr1p3_DualLR_2209-2.0.7.2-src file

  1. Changed the Drivers to TMC 5160
  2. uncommented #define TMC_USE_SW_SPI

only Z(L) moves and its end stop works .

I need Z® to move too and incorporate its end stop during (Auto Home / Auto Square)

Any help will be appreciated

so I did some testing one home Z this morning

  1. I unplugged Z2 (right) end stop and both Z will move 1m and stop
    2.I unplugged Z1(Left) Z2 (right) end stops and both Z1(Left) Z2 (right) will move 1m and stop
    3 .Plug both end stop in and only Z1(left) left will start moving up until I manually push the end stop .

I have double checked all my end stop and there is no problem with them .

Have you checked with M119? Are you sure you have them on the right side?