Blown up, Sir! (Optlaser PID LPLDD)

Well the magic blue smoke is out of my 10 amp Optlasers PID LPLDD driver.
I got the driver to power my NUBM44 diode. Got the TEC Diode cooler working. Then I went to setup the diode driver. I made the test load per the instructions. With a TTL @ 127 I got 250mV at the test pads (=2.5 watts). My Fluke only goes to 400mV so I slowly increased the TTL signal out of the controller, everything looked good for 5 watts at full power. When I got to a TTL = 255 the driver ran for a few seconds then POP!
It was probably one of the most spectacular failures of my short career, there were flashes, pops, and magic blue smoke. I can usually figure out pretty quickly what I did wrong, but this time not so much.

I emailed optlasers and the CEO and owner of the company wrote me back. I’m returning the card for replacement and he’ll see if they can figure out what went wrong, or more likely what I did wrong.

The yellow square on the photo is of a blown resister in the TTL circuit but having the correct 5v on that line, that shouldn’t have failed or caused the failure.

PSU 12v 26amp. I’ve ordered a 7.5 10amp PSU for the diode circuit for the replacement driver.

Any Ideas?

[attachment file=52203]

Heres the diode cooler controlled by the PID LPLDD board. It seemed to work really well…

Keep us in the loop, I am sure no one else wants to pop a component.

Will do.

Well the spec sheet says “Laser diode supply voltage 3,3 - 24V”.
It should say “Laser diode suppply voltage 3,3 - 24V as long as you pick it 7.5v”
Ordered a 7.5v PSU and Amazon shipped a 5v so I tried that and the card didn’t work.
While waiting for the new 7.5v to be shipped. I tried the 12v PSU I had.
Theres where the trouble started.
Diode SK84 was burned, short circuit on amplifier, and Mosfet gate.
So now I have a 7.5v power supply and the card is on its way back, so we’ll see.

This card is kicking my butt. Per the website instructions every 100mV read on the test pads is one amp to the diode. When I do this the max reading I can get is 64.4 MV. So just over half an amp. When I hook the meter inline with the diode and take a direct amp reading I get 1.9 amps. I’m driving a NUBM44-81 diode so it should take 4 or 5 amps and the max I can get out of this card is 2 amps.
Is my thinking messed up? I’m I doing some thing wrong?

Info sheet:

diode NUBM44-81
PSU for diode 7.5v 10A
PSU for card 12v 29A


  1. The method of reading amps to the diode is wildly off.
  2. I can’t get more than 2 amps out of the card.

PS after getting the card back from repair I found they replaced the SK84 Rectifier with a shorting bar… I could have done that!