Buzzing sound at low speeds

When I run the machine at speeds under 500 mm/minute I notice a noticeable buzzing or almost grinding sound. When I speed things up to 1000 mm/minute it sounds pretty clean. I have checked most of the bolts and they seems appropriately snug and the belts seem tight enough as well. I cannot see anything that is vibrating but most of the sound seems to be coming from the region of the middle assembly. If I add some pressure on the belt while the machine is running on the between the pulley and the trailing end roller the noise gets better. Adding pressure anywhere else doesn’t seem to do much.

Has anyone run into this before? Is this a real problem or just an annoyance? Is there a simple way to fix this? I haven’t tried cutting yet but drawing with a pen at the slow speeds seems to work really well.

Ramps? what kind of drivers What are they set at, what step rate, what size steppers rated amperage?

Most steppers make noise when they are powered up, If you got the kit from here you are fine, If you got your own parts make sure you set the stepper drivers appropriately if they are over powered they hum and can overheat.

Its a 3rd party thing I got on ebay but seems to work fine. I don’t think the sounds is coming from the motors, it seems like there is some sort of vibration somewhere in the machine. The only noise/vibration is when the machine is moving under 500 mm/minutes. If its fast or stationary there are no sounds. The motors don’t seem to be getting even warm, this issue happens even if I just turned things on. I will have to double check all of the bolts to make sure something isn’t loose somewhere.

Could be a lot of things a video would help narrow it down.

Here is the video:
Here is a screen shot of LinuxCNC motor settings:

After the compression the video doesn’t look great but you should get the idea. The actual motion does look pretty smooth in person. Please note that it sounds great at the beginning as the machine homes and sounds fine as well as the pen picks up and moves to another location. Nothing is getting drawn because I purposely increased the z position to rule out issues related to the pressure of the pen on the table. I measured the distance of the basic single axis lines and they were pretty much perfect so my dimension (and hopefully the rest of the motor settings) should be correct.

Those settings are completely different that what the standard setup is. I have no idea what hardware you are using but I would guess your drivers are way to high. 4x microstepping and no pulleys?

We use 32 microstepping and 16tooth pulleys, and higher top speed less acceleration. Lower micro stepping would cause louder movements but not that constant buzzing. The only way I can make that noise is totally over drive my stepper voltage.

Maybe someone with some linuxcnc experience will step in here. But you will need to list all your hardware with specs and electronics as well.

I have attached the pdf document for the driver board I am using. As for the stepper motors, they appear to be standard NEMA 17’s. I haven’t found anything different about them compared to any other 17’s I have seen online.

Also, I have the same pulleys with 16 teeth. In my settings I have the teeth set to 1 instead of 16 because of what I have read online about how to set up LinuxCNC when using tension belts. It is my understanding that the setting in the screen shot were originally designed for lead screws so some conversions are required. I read some posts about this and stopped making changes once things appeared to work and the scale was correct. I am not 100% something isn’t incorrect that might cause the issues shown in the video.

3_Axis_TB6600_CNC_Driver_Board_Users_Manual.pdf (1.73 MB)

What current did you set them to? Nema 17 is the face plate size the length can vary a lot. Your steppers should have a current rating as well. You can do it by trial and error but things are much easier and safer if you find a data sheet.

If you can’t find the proper info start by turning the current down until they are pretty much silent while idle.

I believe there are the specs for the motors:

Manufacturer Part Number 17HS19-2004S1
Step Angle 1.8°
Step Accuracy 5%
Holding Torque 59Ncm(
Rated Current/phase 2.0A
Phase Resistance 1.4ohms
Voltage 2.8V
Inductance 3.0mH±20%(1KHz)
Weight 400g

After looking at the documents I changed the current from 2.8A to 4A since there are two motors per channel but that didn’t seem to make any difference. There hasn’t been an noise or vibrations when the motors are on but idle.

Try turning them down, not up.

2A is max, and they will get really hot. Amperage also depends if they are wired in series or parallel. Turn them as low as they can go and see if that stops the noise. If it does you found the problem and can turn them up if necessary. If that doesn’t stop the noise we need to look for other issues.

It also says 18-40Volts are required, what size power supply are you using?

Changing down to 1.6A did seem to help some. The 0.4A setting is too low so I will have to stick with 1.6A for now. My power supply is 24 V @ 8.3 A which should be more then enough. I may eventually switch to RAMPS but want to get this working initially at least.

I think I might have fixed the problem. I changed the microstepping from 1/4 to 1/16 and the motors got really quite while running. Other than that, everything else appeared to work the same. I am going to assuming that was solution but is there an explanation why that would work? I changed the LinuxCNC motors settings and driver board accordingly.