Canceling job on 35tft causes the steppers to disable

Also canceling the job from the touch interface immediately drags the router to the home position without lifting or turning off the spindle. I’ve looked everywhere and nothing seems to help. I enabled sdsupport and #define EVENT_GCODE_SD_STOP “G0Z60” doesn’t run. Am I missing something?

Which way are you using the tft? In the touchscreen mode or Marlin mode?

Which version of Marlin are you using?

Sorry it’s a 32tft and it only has the touchscreen mode. Marlin 2.0.

And you’re running the job from the screen, and you cancel on the screen?

My guess is the problem is the firmware on the screen, and nothing in Marlin is going to fix it. What firmware are you running on the screen? Is it a bugtreetech tft screen?

go to the very end of the TFT firmware configuration.h file and see if there is anything filled in for the end or cancel g-code sections

it ships with commands that disable the steppers I currently have mine blank as i dont need it to do anything on its own

Thanks. I was looking at the Marlin side and not the TFT side.