Cannot find the *.ino file

Hello. I have a RAMBo card, and want to use the Auto square, dual endstops.

I try to follow the receipe at

It says that I shall “Open the firmware folder and select the current .ino file”

But I cannot find the file.

I hope someone can help me with this, as it is a total showstopper for me.

You have to download my firmware from github for the Dual endstop. At this time it takes some firmware editing so if you are not comfortable with that I would wait until it is a little more mature. That firmware is built on a beta base of marlin so it is ever evolving right now.

1 Like

Is it the github project found at ?

I can still not find the *.ino file.

I can do firmware editing as long as there is a recipe on what to do.

Alternatively I can go back to the old way with pairs of steppers controlled by same channel.

In that case: do I have to roll back some of the operations from the recipe at ? (I successfully executed the steps before “Open the firmware folder and select the current .ino file”)

Did you unzip the file? There really isn’t a recipe to follow yet, I am unclear on how comfortable you are messing with firmware but if you get in a bind you can just flash back I guess.

Yes I unzipped the file. I also tried to clone the project. I have worked with git for years. I cannot see the *.ino file in the project.

It is in the Marlin folder.

Thanks a lot. Found it: Marlin.ino (The name is wildly different from the example at So that confused me.)

Now I get a different problem:

When trying to upload the *.ino file using arduino ide, I get error message:

Sketch uses 104324 bytes (40%) of program storage space. Maximum is 258048 bytes.
Global variables use 4571 bytes of dynamic memory.
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer
An error occurred while uploading the sketch

I am now ready to skip the “dual endstop”.

But since I want to use the “Full Graphic Smart Controller”, so I assume that I still need to flash firmware. And the the above problem still has to be solved.


That means it is not connected, did you select the correct com port?

If you got the board from me it comes ready for the LCD, and from the looks of it you have not flashed it so it should still be fine.

Hi Ryan

I’m building the MPCNC together with Frode Mjos Johnsen. We wish to update the firmware to use the new “Dual Endstop” hardware solution which requires a firmware update. Is this not necessary? Good to know that the pre-flashed firmware is ready-setup for the LCD display :slight_smile:

-Knut Olai

If you bought it from me as the dual kit, it comes preflashed with dual firmware.

At this point I have no idea what is going on with the board. I suggest plugging in the lcd and seeing it it works.

  1. Will do that first thing tomorrow. Sorry for the confusion. We bought the RAMBo and LCD display a few weeks before the Dual Endstop firmware was released so we assumed the RAMBo was flashed with the old (non-metal) firmware?


Tried the LCD display that we bought together with the RAMBo. It lights up (blue screen, no text), but is unresponsive to the button or knob. All fuses on the board seems fine, the power LED is shining and the status LED blinks when power is connected and when the reset button is pressed. The LCD display also shuts restarts when the reset button is pressed.

Swap the wires, there are 4 ways to plug it in 2 of them will light it up and only 1 actually works. You are using the adapter from me as well correct? If you bought the adapter somewhere else chances are really good it is backwards.


Got the LCD display working. Swapping the wires did the trick. Kinda odd though as now EXP1 on the LCD is is connected to EXP2 on the RAMBo (and vice versa).

Your observation from an earlier reply: "

When the RAMBo is powered by our 12Volt supply the power LED light up (Green light). However this is not the case when only the USB cable is connected (our setup for the failed firmware upload). In the firmware guide it’s not stated that the 12Volt supply is necessary for programming the board.

We will make another attempt at updating the firmware from the “Series” to “Dual Endstop” with the 12Volt supply connected.

Sorry I will change that, you need power and usb for ultimachine boards, it’s a safety feature to keep the circuits as separate as possible. Pretty sure I have it on the other page but that is vital information on the flashing page.


Tried uploading gain with the 12Volt supply connected and the process was now successful! Now to mount the Endstops… Thank you for the assistance! :slight_smile:

I know this must be a crazy question…mostly due to the new hierarchical arduino sketch.

I clone the “Marlin-MPCNC_Rambo_T8_16T_LCD_DualEndstop” branch from GitHub.

I can find the Marlin.ino folder and file.

When I open it in the IDE, I only have tabs for *.h files that are in the Marlin folder.

Where do I find the dozens of other *.h and *.cpp files that have to be compiled when I upload to the RAMBo?

Do I need to use a newer version of the IDE? I am currently running 1.6.7

Again…thank you for the MPCNC. I have had more fun than I could have imagined with this thing

Marlin 2.0 doesn’t work that way you will only see the config files, the rest compile in the background. You should not need to touch the rest, that is kinda the point of the restructure.

You should use the newest Arduino at the minimum and most have more success with the current arduino beta.

1 Like