Cannot zero the Z axis - no fancy hardware/probes

Hello. I just got the MPCNC Primo working with the Rambo 1.4 board. I am trying to get it to mill something and I cannot get the Z-Axis to 0. I do not have any fancy touch plate equipment. From the comments here I tried everything I have seen and nothing seems to stop the Z-Axis from wanting to drive itself into the ground.

The LCD is always blinking with the Z-Axis, always. I can move the Z-Axis via the LCD panel, no problem. I can zero the X and Y axes, no issue. G28 X Y

I use the G28 command to zero the X axis and Y axis, no problems. I issue the command from Repetier-Host V2.1.6. There is no issue there.

I tried the advice in the help system to use the G92 Z0 command to set the Z access relative to the current position, and my milling project still had issues as my CNC router again tried to move itself into the ground, past my board :slight_smile:

The command to set the Z-Axis relative to where it is currently at did not seem to work.
G92 Z0

The echo from running the command may shed light on the issue. I am unclear what to do here. The echo may indicate I am 8000 units (millimeters?) off where my relative 0 is. Is this what the echo is telling me? If so, is this a firmware thing? 427 D Marlin

The count is the number of steps sent to the motor. It is telling you that you moved it 8000 steps (so probably 20mm) so far. G92 doesn’t affect the count, but unless you are a developer, I don’t see a good reason for you to care.

The feedback from the G92 looks good. Part of the confusion might be that RH is dumb and doesn’t recognize the G92. You can do G92 X0 Y0 Z0 and then send @isathome, which will tell RH that you are at home.

It would be best to start with the test crown, which has a G92 at the top. If you can run that, then your software and electronics are fine, and we need to work on the CAM.

Thank you very much for the super fast response. I solved the problem by loading up the crown example you linked to. It works just fine. I suspect that Fusion 360 put something into the .nc file that is not so healthy for my Z-Axis :slight_smile:

The crown example works just fine. Both the crown test model and my model start out with the following:

G92 X0 Y0 Z0

The .nc code must be an issue after that. I do not have time to resolve it tonight, but I suspect the following lines on the crown sample model are also helpful.

G00 X0.0000 Y0.0000 Z0.0000 F2100
G00 X0.0000 Y0.0000 Z5.0000 F500

I am not a CNC guy just yet. Thank you very much for your help. There is clearly a problem with my .nc file coming from Fusion 360. Perhaps Estlcam must be an intermediate step – trying to skip it and get rolling right from Fusion 360

Thank you!

**To all of those also experiencing problems, kindly reference the excellent advice and the sample of the crown linked to above.

1 Like

What post processor are you using with Fusion 360? Are you sure you defined your stock correctly and selected the right home position relative to your stock in Fusion 360?

1 Like

The post processor is Grbl … but that may need to change. I did see Ultimaker 5, but I am unclear what board I have besides the Rambo 1.4. The board is made by Ultimaker. Perhaps there is a bit of an issue there. I will get it figured out. If you know, please let me know so I don’t have to hunt. This is a very good point.

The stock does seem to be defined correctly. I am a newbie and am just milling fictitious stock in the air at this point. The problem was with the Z-axis starting position. It thought home was apparently with the devil, because it keep moving down, down, down, with no end in sight.

I also believe the milling origin as on point with regard to the start of the stock. I suspect the issue is with the post processor choice I made.

Thank you very much for commenting. I am a complete newbie to CNC and did not realize we perhaps had initialization logic differences between board types.

So are you using GRBL on your Rambo 1.4 board? Most people with MPCNC machines run Marlin. If you are running firmware provided by V1/Ryan you are running Marlin. If so, you need a different post processor. This is the recommended one:

I am using 427 D Marlin I am pretty sure I have Ryans firmware, as the first time I did not and had problems with the second X, Y steppers due to some sort of code enabling #define. They all work now. I will check it out tomorrow. I have run out of time this weekend.

…now to eliminate some shake when x and y move together. Perhaps I will pay the price for my wicked ways of using steel 1" tubing and going 4’ x 4’.


Then you will need a different post processor. The hardest thing about alternate post processors is figuring out where to put them. If it is any help, on my windows machine I put mine here: C:\Users\robert\AppData\Roaming\Autodesk\Fusion 360 CAM\Posts. I use fusion 360 with my MPCNC, and the only problems I’ve had are ones of my own making.

This is Marlin. The Guffy post processor is great. I suspect it is something simple in the gcode (like relative coordinates, or the wrong origin).

He wrote, “The post processor is Grbl,” so that is likely the root of the problem. From a couple of clues in his question, that is what I suspected.

Thank you very much for your suggestion.

Guffy here:
(for those that do not code, you just drop the files (probably just the marlin file along with the file that ends in .js into the directory in Fusion 360 and you are good to go - no worries)

Consult the official Fusion 360 post processing install doc here:

Reading on post-processing here: