Can't load firmware or move motors

I cannot load any firmware or get any motors to turn on. I have a MAC, tried it with Arduino and Platform, nothing. Borrow a Windows laptop same thing.

We need more info:

  • What board do you have and did you get it from the shop (I just need to know to see if it was already flashed)
  • Are you wired up for series or dual firmware?
  • MPCNC or Low Rider?
  • If you post error messages, you need to show us the very first error. They often cascade and only the first message is useful.
  • Share a photo of the control board wired up. We can often spot problems.

I’m sure it is something simple.

The board is a Rambo V1.4

I wired them as you recommended.


Hope this helps

It looks like it compiled, but it can’t talk to the board. Do you have it powered via 12V as well as the USB? You don’t have windows 7, do you?

Jeff, I did have the 12v on as well as the USB

This was a Windows 10 and I tried my MAC as well

It is not connecting. Try a different USB cable, make sure the board is powered correctly (polarity, the right ports, all three fuses still good)?

Sorry everyone, been busy with holidays. Just started again. Not much has changed. can’t communicate with the board. Y axis turns on and hold (gets very hot). Not sure I even have the drivers for the Arduino loaded. Can’t find any in instructions on how to do that.

This is what the board looks like and the error I get with Repetier

The red light means it probably has the wrong firmware. Lets try to figure out why it won’t flash.

Usb cable in, reptier not running, board has the 12V power on, what does platform io say?

Ok reloaded firmware, red light is off. I sent M119 and it read it. Motors are not on and will not move.

Verify you are getting power through the jumpers to the motor power port, if yes, check the 2 small fuses on the board.

POWER AND FUSES ARE GOOD. Reloaded with Platform IO and it succeeded. But still no motor control.

Do you have a screen or is repetier connecting now?

Let’s verify what firmware you have on there. The screen will show it when you boot, repetier shows it in the info when you connect.

I have never seen a board that has all steppers out without it just being a blown fuse, so we have to be missing something very small.

Did you verify the power on the motor in port? You could have clamped onto the plastic instead of the wire.

Ryan, not connected right now. Long day, I will try tomorrow after work.


I did verify 12v power

if you expand that bottom section with the “opengl” you should be able to see error messages or info when you try to connect.

OK I got it working now. Used Platform IO, I think I had the wrong Marlin version. Only one questions? The X2 Endstop reads z2

Sounds like you loaded the Lowrider dual firmware, and are looking for MPCNC dual firmware.