Can't seem to get this running

Hey all,

I’ve my LRV2 all setup, manually moving all of the axis’s they move in the right direction smoothly.

I’ve followed the assembly guide right through to using a pen to draw the crown but when I click print the machine drops the z axis to the ground and keeps going until they torque out, sometimes it’ll move along the X axis also? I’m confused why it’s doing this as I thought the starting position bwas always the top corner of the work space?

The kit came with endstops that I haven’t used just in case that’s a root cause of any issue.

Are you using the test crown gcode, without modifications?

Oh I tried to just follow the steps in the guide I didn’t see a pre made gcode any chance you could link me to it?

Click the link that Jeff just posted, then right click the “Test Crown 12mm/s” link at step 8 and save as crown.gcode

1 Like

Thanks guys will try this in the morning and see if it works. Will figure out if I derped the code or what.

1 Like

Hey, tried the gcode and it worked so great news the low rider is working :slight_smile: I just need to figure out getting the code right :slight_smile:


Good. Now you can search through the estlcam basics and see what settings you missed.

Sounds like you forgot to zero your axis before pressing GO… the machine was just trying to get to 0,0,0 before starting the job


@dart1280 when I turn my machine on it flashes X,Y,Z “?” Is that the machine not homing? I never installed the end stops yet do I need to install them to be able to zero them?

Zero happens where you turn on the machine. If you jogged the endmill to a different location and didn’t send a G92 X0 Y0 Z0, when you hit start, it will move back to where you turned the machine on.

As Barry says…also yes, the X,Y,Z flashes because GRBL does not know where the spindle is. IF you fitted home switches and enabled homing you could tell GRBL to ‘home’ and it would drive the spindle to the limit switches and set X to 0, Y to 0 and Z to 0 and you would position your workpiece in the right place next to the spindle. For a mill it is not so important to do this as it is for a 3d printer (for example) as with milling everything is in relation to the workpiece…not the edge of the work area. So what we do is ignore the flashing XYZ, send a $X to bypass the alarm, then jog the spindle to where you afixed the workpiece on the bed and then tell GRBL that the spindle is at X0,Y0,Z0 with the command Barry quoted (or by a macro or other button set up to do just that.)

Just never hit “home all” button. The Z endstop is usually a touch probe. If the probe isn’t there, it will try to drive(probably successfully) the end mill into the table.

1 Like

So you have a touch plate to stop the bit from driving into the bed. Do you guys do something to stop lifting the Z to a point where the Z tube will pop out of the frame.

Nope, just a little carefulling.

1 Like

What isn’t mentioned here whatsoever is the G92 x0 y0 z0 gcode and how/ where you need to put it.

Depends on how you want to use it. Ryan adds it to the beginning of his gcode so you just have to set the endmill where you want it and hit go. I have it set as a macro in repetier host.

Is there a guide/ video as to how I can do this because I’m really bloody confused and this doesn’t seem to be covered in any of the documentation.

We have some documentation here. Let me know if that makes sense to you. I’m not sure how many people have read it, or gained anything from it.

It’s unlikely to happen, and even if it does, it wouldn’t really be a problem. The lead screw would just sit on top of the nut, the two tubes wouldn’t exit the top runners (or even maybe the bottom ones, depending on how long you’ve got it.)

If you really wanted to, you could enable the software endstops in the firmware, (set your #define Z_MAX_POS to some max and define MAX_SOFTWARE_ENDSTOPS) but that would likely cause more problems than it solves.

I ran into this same problem, but you’re getting good advice.

Depending on what you use for your cam software you just need to add that little bit of gcode (G92 x0 y0 z0) at the start of the cnc program.

As an example in my case I use the LCD screen as my lr2 controller, and I make my cnc programs with estlcam (my cam software). In estlcam in the setup drop down, cnc program setting, there is a tab for program start. I just put that G92 x0 y0 z0 in there and save it.

Now each time I create a cnc program by default it starts with that code then runs the program. As others mentioned the g92 command tells the lr2 that wherever the bit is, is now the origin x0, y0,z0. So all the moves the lr2 make are relative to that point.

What is happening if you don’t run this command is that wherever the bit is when you power on is the origin. If you manually jog the bit over to your workpiece and try and run a cnc program that doesn’t have the g92 command, the cnc will go back to where you powered it on and make all the moves from that origin, not the place you had just moved it over to (your intended new origin).

Hope this helps. I know I thought I was going crazy when I encountered this.