change steps to mm (solved with guide)

Paulo Rogério de Oliveira You can change it at easy, using repetier host, i.e. Just connect RH to arduino and Alt+E. When you upload firmware first time, default values (from configuration.h) copy to eeprom. When you upload it again, eeprom is already there, and will ignore your new defaults. .


hey guys,

i made changes to the firmware and uploaded it as it confirms that it took but i change the defaults from 200, 200 to 100, 100 but it does not take or show up on the lcd.


help please?



How did you upload it? If you tried to change it from the LCD eeprom edits are disabled (90%sure), you have to flash through the arduino program after you edit the firmware. If that is what you did can you give more information to what steps you took?

I was able to change it via the lcd but it moves in the .01 steps and moving from 200 to 100 was going to take a while.

i have the IDE and opened up mpcnc813glcd and modified #define DEFAULT_AXIS_STEPS_PER_UNIT { 100, 100, 2267.72, 200 } //MPCNC

i uploaded the tool menu but i connected via usb com5 and then hit the upload.

as it was done, it restarted the lcd screen and i check but no go.




If it didn’t flash successfully there should have been an error message at the bottom of the arduino window in orange.

You selected com5 and then hit the right facing arrow icon (or ctrl+U, or sketch-upload)?

yea i hit the right facing arrow and no error message


Oh, did you change the max feedrate or the default steps per axis?

So i went back and plugged in the box to normal power and usb power and still a no go? I have the 4988 vs the 8825 installed and get massive movement. any other suggestion on what i am simply doing wrong.

I am using 1.8.3 for the IDE

You followed my flashing instructions from the firmware page? Either your changes should stick or you should get an error message. Try to unplug the arduino and hit the right facing arrow and make sure you get some avrdude or timeout messages.

Sir, this page? i know there was another page I thought before.




I did the upload without being connected and it gives the error that nothing is connected.

used repeiter host to make the changes, that was awesome, got additional help from FB.



??You can’t use reptier to make the changes, at least not permanently.


Not to say you are wrong but well i use Alt E to open the setting and inputted them and then went to the LCD and saved the update. In the last few days i have turned this thing on and off so many time and the update stayed…so you might be wrong. =P

Depends on which version of the firmware you have only one of mine has the eeprom editable. Because of that some people have been having issues so firmware updates from here on out will not have the eeprom editable. It makes it to hard to diagnose problems so it is best to think of it as temporary.

If you are not going to make the firmware so that it uses the eeprom, I would suggest adding in a guide to clear the current firmware. This was my problem and why it would not take, I was uploading after changing but it was seeing the changes to the default and ignoring them as it was there already. I will restate that as I some times type clear as mud, when the firmware is on the machine, any changes to default settings will be ignored on firmware pushes and have to have the current firmware erased first. Make sense?


M502 should clear it, and the next round of firmware with it off should also take care of that.

Unfortunately you stumbled on a unique situation, this has not happened yet since I started this thing. I enabled the eeprom for tuning on the last round of firmware and forgot to turn it back off. It had not effected anyone else as no one usually changes those settings in that way as they are usually temporary (per boot). I have always suggested as I did to you to flash firmware with the updated values. It is confusing so maybe I will spend my time today putting out a firmware flash so no one else stumbles into this situation.

Sorry this caused you such a sticky situation.

this was not a bad problem, as i am coming over from another style making. All i am saying is that it would be better to be able to leave it open to being saved, for the 3d printing side of things, the ability to fine tune the machines down to the not even number is critical for fine prints and to be truthful, you have a machine that is more than capable to do very nice printing. the other printers i have in the 80.xx and 80.yy range of fine tuning.

just my two cents from a common CB… =P

The steps are set mathematically, you should have no need to fine tune the firmware. Certain pulleys have certain steps, if that is changed the firmware needs to be updated.

with the 3d printing, the set steps would some times make ovals vs circles so for making things that assemble or screws, it would not fit. but then again, i did learn a lot more on the firmware so i consider it as not so much of a problem or time wasted as it benefited me.

=P again, i would love to you see you leave it in.