Chinese Ramps 1.6

(the last post seems to have disappeared so I am re-posting this)

I don’t know if this really counts as hardware development for the MP3DP, but as the ramps 1.4 was dropped from the store not that long ago, and I am a ramps runner I thought these looked interesting.

So I am running ramps on my new MP3DP I made. I was using a relay, and I have had to run my anet a8 bed through a relay as well, but that was always annoying. Anyways, I was looking at getting some spare ramps (cause I only seem to have a 50% success rate with them) and I saw these ramps 1.6??? Well they were 8 dollars (vs the 3 to 4 for 1.4) and they looked to solve most of my issues (supposedly 270 watts and has better mosfets with heat sinks, also i like that you only have to run 1 set of wires from the power supply, no 11 and 5 amp stuff)

Anyways…. I just switched it out for my ramps 1.4 and it seems to work fine. I will play around with it some more this weekend I hope and see how it does. Does anyone know anymore about these? I bought 2 and they both work so for me that is better already than my success with ramps 1.4. The heat bed and hotend seems to heat up in good time, which was something that always bothered me in the past.

[attachment file=57134]
[attachment file=57135]

https://www.aliexpress.com/item/Bigtreetech-Ramps-1-5-upgrade-base-on-Ramps-1-4-3D-control-panel-mainboard-Reprap-Mendel/32822208144.html?spm=a2g0s.9042311.0.0.iACWyT

1 Like

Have you managed to find any documentation for it?

I was sent one of these a while ago, it was called a 1.5 then.

All this tries to solve is them putting shotty components on there Ramps boards. They have dumped the heat from the mosfets into the pcb (which is fine if they used High quality thick copper PCB’s but…) instead of allowing for heatsinks to be attached, and changed a plug. The board, the 1.5, and the 1.4 are fine, but solder bridges and worse and worse components are killing them. The final straw for me is when they started messing with there arduino’s as well. The 5V regulator they are using can’t even support a few LED’s, and the USB started to have connection issues as well. Trust me, every order I got they got worse and worse.

There have been no design changes. Ultimachine designed the ramps, the next board they made is the Rambo, I would call it ramps 1.5. Any other “ramps” derivatives is a patch, the actual upgrade is a different board, I chose UltiMachine. It has all sorts of driver and I/O protection, isolated USB, and extra I/O (which you can control from the firmware!).

I truly understand the desire to have such a cheap board but at some point you get tired of replacing them (supported thousands over the last 3 years). Factor in time and money spent and any board is going to be better. And I can’t say enough goods things about digipots…

2 Likes

Looks better than the old ramps. I don’t know if any of the other “features” are any good.

I can vouch that the build quality isn’t exactly awesome, at least on the “v1.6” that I received recently (one of the header’s was soldered on askew and will need to be redone). However, to be fair, it should work with the TMC2130 driver that I got for testing. The board itself seems to be little more than an interstitial board with a few discretes on it, so there doesn’t seem to be much that can go wrong with it (famous last words). In contrast, the rambo has A4982’s soldered on, so with Rambo you’re married to the drivers it comes with.

At the moment I have no idea where the SPI jumper wires used on the TMC2130 should connect to on this board. Anyone know?

They are on the ISP port, which isn’t connected on this board, but maybe you can go around and connect straight to the mega? I think they are also on pins 50-54ish, so maybe just use a multimeter to beep around and find them. They are all written down in the pins_RAMPS.h. As for the CS pins, maybe the servo outputs would be good candidates?

As soon as I hit “submit”, I thought about the fact that they are on the exp ports… Duh.

Also, the einsy rambo has the tmc2130s all wired in (as Ryan said, it’s more expensive, but if you don’t enjoy doing all kinds of electronics wiring and debugging then factor in your time).

Aha, apparently it’s AUX-3 that contains the SPI connections. Here’s a handy diagram:

1 Like

Ryan I completely support you on ditching the ramps boards in the store. I think it was a smart move on your end.

Im doing these for kicks and goggles since I’ve used the ramps boards for a while now and I agree they keep burning out, that is why I tried these. Plus I like switching out the drivers and I have some tmc2130’s coming and wanted play with them.

david thanks for the diagram, I didn’t think too far ahead about spi jumpers. Ina month or so when I finally get the drivers I’ll have to muck with that as well.

I guess it kinda came off wrong. What I really meant was try any other board then the import “upgraded” ramps. There are so many cool boards out there. For the price of the imports get a Grbl and an arduino/marlin based board.

1 Like

Ryan, I was misunderstanding your comment. Thanks for clarifying. I will check out some of the other boards, the grbl looks interesting.

Never had a single problem with a Ramps board yet. And just one defective Arduino so far.

In China you usually get what you paid for. If the price is super low then you can be sure there is a catch. If you don’t buy the cheapest of the cheapest after bargaining again and again, then you usually can find reliable stuff.

Personally, I don’t see any good reason why using any other board than the Ramps, this board can basically do anything we need for super cheap and you can replace stuff. I wouldn’t move to any other board unless there were some real improvement (faster speed, essentially)

I’m no fan of Dupont cables for anything more than as an extremely temporary stopgap, so I may make an interstitial PCB board that will handle all the wiring connections more compactly.

Anyhow, I’ll first see how well the TMC2130 works for the x-axis. If that meets expectations, then I’ll order TMC2130’s for the Y and Z axis also.

I also received a TMC2208, but now I’m noticing that I can only do a one time configuration on it, via USB, and right now I don’t know enough to make a wise choice about what that one time configuration should be. Hopefully, I’ll learn enough from the TMC2130 so I can choose.

 

By the way, the board I received is different from the board I ordered: https://www.aliexpress.com/item/Bigtreetech-upgrade-Ramps-1-5-Base-on-Ramps-1-4-3D-control-panel-printer-Control-Reprap/32822038995.html?spm=a2g0s.9042311.0.0.lA5f5S

The board I ordered has the detachable power plugs, whereas the board I received doesn’t. So, it appears they cheaped out.

I think it is for the best, those plugs are a huge weak point on the imports. Screw terminals should be the better option.

Ah, I take it back. Looks like it’s the Ramps 1.5 that came with the plug, not Ramps 1.6. Well, that’s consistent with what you’re saying at least.

Gosh, I guess I’m glad now that I didn’t get the plug version:

Who knew?

 

I have beat the hell out of my three ramps 1.4 boards that are on my three mpcncs. I never had any of them in a case. All have just been sitting on the bed of my mpcnc’s. They have been filled and covered in wood chips/dust. I have blown them off with air and knocked them off the bed of my mpcnc on to the floor. I have swapped drivers (while troubleshooting other machines) in and out. I have yet to have any issues with them [Knock on wood]. That said I did purchase a Protoneer board on Jeff’s recommendation just to play around (have yet to install it but figured I would on my next machine I build). I have no objections to trying out a rambo (other than its price tag, which I am sure it is worth it). I just figure when the ramps is so cheap and has worked so well for me in the past its hard to step away from it.

I am looking forward to trying out that protoneer board though…

I know others who have struggled with ramps boards in the past. It must come down to who and how it was manufactured. I feel if you were able to source them all from a decent place that had some form of quality control you would be much better off.

Neil

Yeah the 1.5 still has the plug in. Those plugs have fallen off a number of my boards and I just helped a friend last night who has the anet board and it had the same issue. I really hate them on the cheap electronics, they seem to not attach well. The 1.6 only has one power input and it is the screw terminals which I like a lot better. That is one of the reasons I was interested in the board, again fixing problems with cheap boards that quality ones don’t have in the first place :slight_smile: