CNC cutting in the air - z too high

Yeah, the gcode would answer a lot of questions. Have you tried the test crown? It is known good gcode and is good foe checking out the machine.

I’ll grab the gcode here in a moment when I get to my computer. And yes I did the test crown and it worked fine but then I messed with the firmware.

G91            ; Coordenadas en modo Relativo.
G0 Z1.270 	; Subir Z para ir a Origen y que no rasque la broca el material

G90 		    ; Coordenadas en Posiciones absolutas.
G20 		    ; Unidades en mm.
M84			; Apagar Motores Paso a paso.
G28 X		    ; Ir a Origen X
G28 Y		    ; Ir a Origen Y
G92 Z1.270		; Le indica a la Maquina donde se encuentra de manera relativa el (eje 
			; Estando por tanto el Punto CERO del Z a Z=-1.270


; *************************************
; **         INICIO DE CORTE         **
; *************************************

G0 X22.624 Y22.743 Z1.270 F2540.0
G1   Z0.000 F508.0
G1  Y24.013 Z-1.270 
G1  Y22.743 Z-2.540 
G1  Y33.261  F1270.0
G1 X22.053   
G1 X21.235 Y33.323  
G1  Y21.235  
G1 X22.841   
G1 X22.678 Y21.981  
G1 X22.624 Y22.743  
G1 X23.881   
G1  Y34.518  
G1 X22.053   
G1 X21.513 Y34.554  
G1 X20.977 Y34.661  
G1 X20.461 Y34.839  
G1 X19.977 Y35.082  
G1  Y19.977  
G1 X24.954   
G1 X24.583 Y20.449  
G1 X24.281 Y20.978  
G1 X24.059 Y21.550  
G1 X23.925 Y22.145  
G1 X23.881 Y22.743  
G0   Z1.270 F2540.0
G0 X27.984 Y21.156  
G1   Z0.000 F508.0
G1 X27.775 Y21.170 Z-0.209 
G1 X27.567 Y21.212 Z-0.421 
G1 X27.364 Y21.282 Z-0.636 
G1 X27.173 Y21.379 Z-0.850 
G1 X26.998 Y21.499 Z-1.063 
G1 X26.843 Y21.639 Z-1.270 
G1 X26.998 Y21.499 Z-1.479 
G1 X27.173 Y21.379 Z-1.691 
G1 X27.364 Y21.282 Z-1.906 
G1 X27.567 Y21.212 Z-2.120 
G1 X27.775 Y21.170 Z-2.333 
G1 X27.984 Y21.156 Z-2.540 
G1 X27.753 Y21.173  F1270.0
G1 X27.517 Y21.226  
G1 X27.283 Y21.319  
G1 X27.061 Y21.451  
G1 X26.861 Y21.621  
G1 X26.692 Y21.821  

The PP was written in Spanish and I haven’t taken the time to translate it all to English for final output yet but pretty self explanatory. I have a decent understanding of GCode and I can’t see anything wrong with it so hopefully you can pick up something I missed.

GCode snippet is added to the thread now.

These are the job/material settings that I used in Aspire.

1 Like

Does the z axis move in the correct direction down with - moves and up with + moves

It does, yes. All axis move in the correct directions when homing and manual moves. Base on the gcode that is getting put out by the software I imagine that it is moving in the correct direction based on those commands but it is hard to tell since they happen quickly and are 1-2mm distances, but I have no reason to believe they aren’t other than the fact that the machine raises too high on Z to start with. But if it were reading them backward I would assume it would drive by Z axis into my table.

1 Like

The G20 gcode is telling the machine to treat all units as inches. Is that intentional? I think that the feedarates (F2540 etc) are WAY too high when interpreted as inches per min.

I had modified it at one point to treat everything as inches since I designed the file in inches in Aspire and wasn’t sure if it should output as inches or mm. I’ve since learned it needs to match the machine, regardless of how the it was dimensioned in Aspire and actually did change it back to G21 in the GCode that is on the SD card for the machine but forgot to switch it in the one I posted.

I did just notice however that it is only set to do G28 for X and Y and then sets the Z manually, however when I begin the print it homes all three axis, so not sure what’s going on with that.

Is it resetting you z axis then?g92 1.27 sets the probe thickness to 1.27 inches here

The current process it does when I start the print file on the machine is: Home X, Home Y, Home Z, Raise Z far away from the material surface, Lower Z slightly, Begin tool path.

From the GCode it doesn’t ever call for a Home Z G28 yet it homes Z anyway. So could it be homing and then raising up then doing G92 Z1.270?

Why don’t you use the pp in the doc pages Aspire Post Processor did you print the crown?

Did you perhaps change the firmware to default to inches?

Based on your description I would guess it’s first raising the Z1.270 inches (G91 G0Z1.27) then setting units to mm.

When you say it homes Z, what does it home to? Do you have a limit switch on Z?

Yes I have a touch plate for Z. And I might have, I’m about to test the clean refresh firmware and see what it does.

Well, I thought I did grab that one but apparently I grabbed another version that was based on that one somehow. I have that version now so will be testing in a few minutes.

I hope so I’m out of (1.2 KB)

It’s working!! Not sure if it was the fw or the new PP but it works beautifully now! Other than it pops up at the end with an error because it can’t turn the extruder temp off lol


Congratulations even the problems are fun and keep you occupied in the end it’s a covered in dust :mask::mask::mask:

Haha luckily I’ve got my shopvac set up for manual dust collection until I settle on a hose mount I like. Now I’m going to spend countless hours cutting random things out lol

1 Like