Cnc doesn't stop at edge?

I bought all the parts directly from the vicious site, including the printed parts to save on time.

I am not using end stops at the moment, however, I have purchased a set of 5 to be installed once they arrive, sometime next week. However, I cannot seem to find a guide on how to install them? So, if anyone happens to know a well put together guide, please link it.

I am using a windows 10 Pc, and I have done most of my tests through Repetier, Estlcam and a little bit of FreeCad.

This is my Arduino Board

So, my issue is, is that when I run Repetier, and run a cut that is well within my build area, my machine seems to head straight to the rails and start slamming into them. Is there a way to set limits for how far it will travel on the X and Y planes? I can’t seem to find a good guide to do that, if it is possible.

Position the router where you want it, then issue G92 X0 Y0 Z0 . This will set your new zero point. You also need to make sure your starting zero point in your gcode is sane. I usually set my zero point in the bottom left of whatever I’m working on. I have home end stops, but nothing on the far limits of travel. I also don’t see the point of an end stop on the Z carriage. The lower end will change depending on your end mill and what you’re cutting, and the upper limit will just unscrew your threaded rod or lead screw, which ever you have.

Also, make sure your gcode and repetier isn’t sending a G28 (auto-homing) command before it starts the cut.

Alright, I’ve tried the G92 X0, Y0, Z0, and upon pressing home, it immediately tries to go through the bars again. Do I set the g92, and then just run the program or is there an additional step?

There is no G28 running, so I think that parts fine. I saw something about the firmware can also include axis size, but I’m not sure how to alter that. Thank both of ya’ll for the help so far!

You can not use the home button, that means, move all axis until you hit an endstop. You shouldn’t have endstops installed so you can not use that button. Home is wherever the head is.

The axis size is turned off in the firmware.

Okay, that makes sense. So, issue a g92, then run my program from there. I am testing that right now, so I will respond in a few minutes. So, is it bad to use endstops on this machine?

Okay, good to know.

I have it in a few places why not to.

I had read the Faq over, but somehow missed the edge stops at the bottom so thank you for pointing that out.

I think I figured out part of my issue, and I’m not sure if there is a tweak for something like this, but it would probably be easiest to explain with a photo. In the two photos attached, I’ve set my zero point in the lower left of my build path, as recommended. However, once ported over into Repetier, it seems my print bed is turned 90 degrees and that is where my issue was. When I line the program up the same way, it should work but it was actually telling my printer to run outside the bars to the left, hence the slamming. So, by pushing my spindle to the far bottom right corner instead, it did move to the proper area and cut. I just have to change where my home is basically.

In repetier if you press the right arrow + does it move right or away from you?

If it moves away from you have your x and y axis reversed.

If you run the sample logo file I have linked in the getting started it would test for proper orientation and direction.

The photos are fine. Estlcam has x along the horizontal lines. If you look at your repetier photo, it’s showing y along the horizontal lines. You can rotate it any way you want.

Also, that black dot is where the gcode’s 0 point is. Make sure where ever you start, the router can move to that location.

The X+ Moves to the right, the x- to the left, Y+ back, y- forward.

The main issue seems to be that instead of the origion point in my cut paths being the lower left black circle, they are originating from the area I circled in red, so after I moved my tool to the bottom right, it seems to be cutting correctly. I mean, it moves nearly all the way to the left side of the tool and cuts in the proper section and side of the machine, it just doesnt seem to work if I set that as the xyz home?

Can you run my file so we can rule out hardware issues and verify it is in your CAM.

“Home is where the Head is”

Needs to be made into a Plaque NOW.

I think I’ll get one cut to mount on the side of my CNC this weekend.

Running it now. I dont have a pen holder so it came out kinda half-assed, but I plan to make one soon. However, this test worked perfectly. It ran from the lower left, and began drawing on the paper I taped down. I’m not sure what changed between this test, and the estlcam test with the knife board though.

Yea, thats pretty good lol. I’m in a machining class and i’m learning cnc, but I think the way that one works throws me off on this one a bit :confused: it doesnt help that I don’t know a Ton about a normal cnc lol

I am always looking for a better way to say that and a better place to put it on the site. One of the biggest questions to date.

Thank all of ya’ll for the help, I will post if I have any further questions once I begin cutting things, but for now, I think I’m ready to go!

Home is where the Spindle starts?

One thing to get in the habit of that I was taught when learning to run a cnc lathe is make sure you learn your terms and be consistent with them. As I see things there are 2 main locations in a machine running g code, “home” and “zero”. Zero is the most important cause all home does is get the tool out of your way. Home, as Ryan pointed out earlier, is a far as the machine will go in a given direction until it hits an end stop. Zero is the point you set before running a program for your reference of where you are starting from. The machine doesnt care if it is at zero or not. When you start the program its just going to go in whatever direction for whatever distance the next line of code tells it to. Zero is good to establish because if you have to stop the program mid run then you can bring the tool back to the point you started and begin again.

Two other important terms are “pause” and “stop”. Pausing a program stops the tool head and the code pauses right there. You can then clear and obstruction or whatever and continue and the program will keep going. If you Stop a program the tool stops right there and the program resets itself. Which means if you hit start again without going back to “zero” the program is gonna start over right there and cut places you dont want it to.

Sorry for the tangent but these are good things to keep in mind which will keep you from have as many “oops” moments later on. Good luck on the new machine! I cant wait to get back into it soon.

Alright, so my machine is now working correctly, with the zero point being the lower left section of my setup. However, on my first cut, it appears I am not exactly lined up correctly but I wanted to make sure that these issues were just due to it not being fully square’d up.

I know that not having the machine square will lead to it not being square during cuts, which happend in the hole parts of this cut pretty obviously. I’m not focused on the travel cuts because my board does have a slight bow in it, which I am sure is causing the lines toward the top.

The part I’m curious about is on the outline of the piece, in the circled area, the bit dropped down to begin cutting, went around once, and settled about 2 to 3 mm’s over from the first cut. It never went into this line again, so I’m not sure why it seemed to randomly move itself over? Is that another symptom of non-squaring?