Cncjs 1.9.22 running on raspberry pi 4 desktop problem

i was running 1.9.22 on raspberry pi 4 8g on the desktop version , my system crash and i had to reinstall the version 17.1 from but now the problem is when i tried to install the desktop it do not work i have 55 error i talk to peopel on facebook and they say thing have changed on the raspberry site it is why it do not work and i dont have acces to the file to fix the problem somebodie can help ?

Does it have a connection to the Internet? It needs internet to download the software to run a GUI.

yes it does connect to internet ,they told me they change something on the site and the script is not pointing anymore to the good place !
what the guy told me (raspbian Buster is indeed outdated. It’s now Bullseye. The dist-upgrade should help. Otherwise change your source file to oldstable instead.)

look the link i think last night they change something

they just told me (Edit your sources.list for testing and not stable, avoid putting the name of the release so it will remain in testing instead of possibly going stable, testing is more suitable for users in desktop mode.
Do not forget contrib and non-free if you use them otherwise doing without such repositories is desirable.
Then upgrade (dist-upgrade) then update (upgrade) as mentioned above.
If you want to have it easy you can try Diet pi but I still recommend you to learn Debian and how to do a command line install, there are just 5 major linux distributions (Arch, Debian, Gentoo, Red hat, Slackware) at Apart from these a handful are really worthy of interest and many will trap the user in a sphere of abusive simplification, there is a way to simplify without harming the learning curve of the user because knowing gives him the power to fish instead of depending on others and having to flee at the slightest change, so to personalize your system is to appropriate it.
Note that the unstable / sid branch of Debian is a rolling release like Arch if desired, but the stability will decrease as it decreases with testing.)

look my answer below

This sounds like someone taught in the theology of linux.

The simple answer is that I need to update the image and I haven’t.

Starting from a blank new raspian full install and adding cnc.js may be the easiest workaround for you.

Or going through the hoops to change the sources.list, but I would find a source of that fix that you trust. The ip address link doesn’t give me any comfort.

Learning debian when you just want to install a gui to run cncjs on a pi is not required. The whole point of the pi is to bring new users in, not to require them to be experts.

But that is just one person’s opinion. They are entitled to their own.

1 Like

but the problem i tried to install cncjs on normal raspberry pi system and i cant make it work :frowning: i am used whit visual studio for modifyng the source for the cnc but this one i dont now how to modify it if i new i would do it
what software do i used to compile the source code for shure if i run it it will tell me the 55 lines who is not working ?

i am not an expert like you !

I wish I could help more. But I have a lot on my plate and updating the v1pi image is not coming soon.

Good News Jeff !

i used balenaetcher to burn your latest image and run it on raspberry pi4 8 g after booting the setup complete i run sudo apt update after reboot and sudo /home/pi/scripts/install-desktop and it install it
after booting on desktop i had to install a webb broswer because your version do not contain one !
and log to http://v1pilocal and it work this is the solution to run the desktop sideways to the cnc before you fix the bug whit the newer version !

By the way the default login password is pi raspberry on your version

Jeff is it possible when you make a new version of it including the desktop option to have an version whitch included more fiuture and chromium and dual display hdmi because the current version was not included !
i now i ask a lot but i am using it directly plug it to the cnc and i am shure few people would like these feature included !
Thanks Jeffeb !

No. The v1pi image is meant to be headless. If you want that, you should set that up with a separate pi and use the v1pi to just run the machine.

oh whell what can i say !

1 Like