Command to keep stepper motors on

What is the command that I can put into my gcode to keep stepper motors on when I have completed a cut? Also where would I input this into the gcode? Thanks!!

They will stay on as long as you don’t add a code to turn them off :slight_smile:

That’s the problem. I design in Easel then run the cut in Repeteir Host but the Z motors shut off and plunge into my project if I am not right there to catch it. So I’m thinking Easel is generating the code to shut them off and I don’t know what code it is.

Marlin:
M84 S0

GRBL:
$1=255

1 Like

Ah - I see! I don’t know the different platforms, but I know that gcode generated in estlcam → run with cncjs leaves the motors engaged after code is finished.

2 Likes

In Repetier-Host, go to Config/Printer Settings and select the “Printer” tab. You want to uncheck this box:

image

4 Likes

Excellent. I will give this a try. Thank you!!

You can open the gcode in a text editor and look at the bottom for M84 or M18. If that’s there, then you need to remove it, or get easel to stop adding it.

I dont see that in any of my gcode I have included the first and last bits of the code if you want to look it over.

FIRST

G21
G90
G1 Z3.810 F228.6
G0 X-195.680 Y-15.893
G1 Z-0.500 F75.0
G1 X-201.508 Y-15.893 F1200.0
G1 X-203.398 Y-15.258 F1200.0

LAST

G0 Z3.810
G0 X192.546 Y-1.200
G1 Z-2.500 F75.0
G1 X190.795 Y-1.200 F1200.0
G21
G90
G0 Z3.810
G0 X0.000 Y0.000
G4 P0.1

How are you sending the gcode? That file looks fine.

It is being set through Repeteir Host. Gcode is generated through easel then opened in Rep host. Robert had mentioned to go into printer options and uncheck the disable motors after job box. I did that and will run a cut to see what happens.

1 Like

Thanks you so much. I was able to uncheck the box and steppers are staying on when the cut gets done. Thanks again!!!

2 Likes