Compiling Error RAMBo 1.4

Hi,

I just got a compiling error from Arduino IDE trying to flash my RAMBo 1.4

sketch\src\HAL\AVR\u8g_com_HAL_AVR_sw_spi.cpp: In function 'void u8g_spiSend_sw_AVR_mode_0(uint8_t)':
sketch\src\HAL\AVR\u8g_com_HAL_AVR_sw_spi.cpp:90:3: error: 'U8G_ATOMIC_START' was not declared in this scope
   U8G_ATOMIC_START();
   ^~~~~~~~~~~~~~~~
[...]

Latest RAMBo board addon is installed (Board Manager) - Board is recognized and I was using the default Marlin linked by V1

Any idea what I can try next?

You need to install u8glib

Thanks - I know that turns into “Arduino for beginners” but that’s what I tried before - result was an avr_gcc error

The default is a landing page and will not work. Did you select the rambo firmware, which one there are two?

I selected the V1CNC_RAMBo_Dual

What version of arduino, mac or pc? Screenshot. There is not enough info to help here. show and tell us everything you can.

I’m now using a fresh installation of Arduino 1.8.13 on an Windows 64 bit system. Installed RAMBo 1.0.1

Error Message:
avr-gcc: error: CreateProcess: No such file or directory
exit status 1
Error compiling for board RAMBo.

This is the third time we’ve seen this particular error. The other two have worked around it by using platformio.

What else can you tell us about your system. Where did you get the arduino download?

The only thing remitely special about my system is that I sync my surface and my desktop by putting Arduino on my OneDrive. That’s why I tried a new install (from arduino.cc) but maybe something from the shared install got stuck.

Arduino has issues with file name length, doing that could add some extra and choke it. I would say give platform.io a shot. I am not sure if most would think it is easier or harder but in the end it takes far less steps and works really well.

https://docs.v1engineering.com/learn/platformio/

Thanks! Platform.io worked - and I really like the features.

1 Like

Good to hear. Software is tough, never know what program most people will find intuitive. P.io might be a winner, so far so good.