Good evening, two days ago I finally got everything moving like it is supposed to being controlled by pronterface, then once I shut everything down for the night and went inside I took my computer with me to figure out how to start using a CAM software then when I went out to the shop last night to try to draw the crown, I couldn’t even get pronterface to connect to my MPCNC please help. I also down loaded estlcam and went through the set up process for the controller through estlcam I’m wondering if something I did during the set up messed with my connection ability. Idk what happened

There is a list of failure points that can cause a communication issue:

  • Bad control board

  • Control board not powered correctly

  • Firmware issue

  • USB cable issue

  • G-code sender (pronterface/EstlCAM) setup issue

  • OS Issue (Windows/Mac)

In order to troubleshoot the issue, you likely need to provide more information and/or do more tests:

  • What control board and firmware are you using?

  • Does the control board have a display? If so, does it show a boot screen? If so, can you move your machine using the display? If you don’t have a display, do you see power lights lit on the control board?

  • How did you set up ESTLCAM for the MPCNC? Did you set up the baud rate? Does it show “connected” when you click the connect button?

  • Have you tried an alternate USB cable?

  • Did you reboot your computer?

1 Like

Everything was working fine two days ago the cable was fine, no it doesn’t have a screen, the yellow light that flashes normally when it connects just blinks slowly now. I have pressed the reset button on the control board, I have shut everything down and restarted, I have the Rambo full size board with the pre loaded firmware. When I set up the estlcam I set it under the arduino mega I don’t remember it asking about boud rate but that’s when I started having this problem after I set up in estlcam so idk what’s going on. It worked fine with pronterface and repeteir host before and now it won’t do anything.

I was trying to use estlcam to have a the CAM and control under the same platform but idk what I did.

Estlcam is fine to use as CAM, but if you flashed a controller with estlcam, it erases the Marlin firmware. Only a few boards can support estlcam firmware.

The more common approach (here) is to use estlcam to create a gcode file and then use something else to send the gcode. You can see some of these terms defined in the software workflow doc.

At this point, you will need to flash the controller with Marlin again. What board is it? We need to get the right firmware from MarlinBuilder releases and flash it with xloader.

1 Like

With the Rambo board, assuming you are using 5 drivers (i.e. one wire from each stepper goes to the control board), then you will need to reflash with V1CNC_Rambo_Dual using the links Jeff provided.

I have one port for x and y then two for z so I made two pig tails to run the two x motors and two y motors to the one port.

I was afraid I was going to have to reflash the board. I haven’t ever done that so I have no clue what I’m doing.

What reader does my computer need to read hex files?

This is what my computer has pulled up for me to choose from.

You can’t read the .hex file. It is the binary data to flash onto the rambo.

To do that you need to use xloader.

Make sure the wiring is in series. It will half the holding power if they are wired in parallel.

1 Like

I actually made the pigtail just like in that document.

1 Like

I have been looking at this screen for about thirty minutes or so, idk if it’s doing anything or not.

It almost acts like it froze up.

Your XLoader screen should look something like:


In particular, you want the ATMEGA2560 and a baud of 115200. The COM Port will be particular to your setup. I’m guessing XLoader is hung due to the wrong baud rate and/or the wrong device selected.

In addition, if you have serial wiring like you indicate, the correct firmware is V1CNC_Rambo (no dual in the name).

Ok how do I get the x loader screen to close since it’s hung up?

And when I hit the drop down bar non of mine showed any of what the one does that you put.

I can’t find the hex file that is displayed on the example your showing but I changed everything else.

This is the point I’m at right now but it said upload failed. I’m sure because the file name is wrong.