Controller and screen are not working

Hello everyone :slight_smile:
I am new here and I just got my CNC built. When I connected the controller and the screen, I got this weird display! I am wondering if anyone had a similar situation and can help.

I appreciate your help in advance


Hi, Carefully match the LCD ribbon cables to this picture,

1 Like

Hi Ryan,

Thanks for your reply! I did connect the same way, and still, I see the same result!

please check attached images

We need to see the entire wire so we can see where it is connected and where it ends up.

When you connect to repetier host do you have any issues, what firmware does it say is on the board?

in this pic we see the entire wire

I can’t send more than one image per reply

I didn’t connect it to a repetier host yet… is there a link where I can see how to do that?

Thanks Ryan for your help

That wiring looks correct, so lets move onto checking the board.

The board and screen were purchased from V1?

yeah… both the board and screen were purchased from V1…

I will look into the link you sent just now
thank you Ryan

I tried to look up the problem … it seems maybe there is a need to reinstall the firmware … maybe … I am not sure! But anyways, it is a process that I think I am not at a level that I can perform. So I ordered a GRBL 1.1 v3.4 board and it worked fine!

Putting new firmware on it is pretty easy but repetier would tell us if it was actually needed or not. Easy test and the best way to setup and test your build.

Hi Ryan,

In the Repetier-Host, I managed to make a connection to the board, but it’s saying that Unknown Printer Firmware. I even sent some commands, but they stayed in the “waiting” list.

What do you think?

Okay…using a mac is not going to make this easier…there can be other issues. What year is the computer, current OS, laptop desktop?

Can you show your connection settings, buad rate and port.

Make sure the board has power and USB going.

Baudrate 250000, That port looks fishy as well, any other options?

I tried the Baudrate 250000. Nothing changed!

Hello Ryan,

Thanks for your help in advance.
I don’t know if you saw my last communication. What do you think we should do next?
Do you think there is a problem with the board?
I was thinking to borrow a PC with windows and try to fix this.
What do you think?

I am not sure how to proceed. I do not know anyone with a mac, or know which ones have the baud rate limitations (some will not work at 250000 and your seems older and could be the issue…

What would you suggest?

My only option is send it in and I can double check it, but you would need to send the board and screen.

Before I send it over.

I am anyway planning to run my cnc from Raspberry Pi 4 with a touch screen. Do you think if I installed the Reptier Host there and we tried to connect we can have a chance? Since it’s going to be windows operating system.