controlling the motors

I recently finished putting my cnc together and downloaded repetier host and arduino like is says to in the software part if the assembly. I am having a problem getting my motors moving. I can open up Repetier and it connects but when i go to load g code and run it or i just try moving the motors in the print panel they will not work. i also have the wiring kit that you can buy as well. Any help will be much appreciated. Thanks.

Can you move them using the manual control tab?
Did you plug in the resistor on pins t0?

I have the resistor plugged in and im on mac i dont know if that has anything to do with it but on mine there is something called print panel. i dont know if this is what your talking about or not.

Yup that’s it, to to move the x or y +10

Okay when i click them nothing happens

Do you have end stops? If so power disconnect the power and the usb, unplug the end stops, power back up and try again.

I do not have end stops but i will power it off and power it back up to see if that works

Yeah powering it down then back on didnt do anything either

Click the Toggle log button at the top of repetier and see if any errors are coming up. If there are none Give Skienforge a try.

That should bring up a line at the bottom of the repetier screen you can drag that window open a bit to show more than 1 line.

the ones in the picture attached are are just x +10 the ones above it are -10 and then some on the y axis

It might just be moving really slow, type each of these lines into repetier hit enter after each line. Yours is going 1/10th normal speed. I think.

G0 Y50 F11400

Wait yours is 1/3rd speed you should be able to see that.

Try skienforge

Is that compatible with mac?

I always assumed so, I haven’t used a Mac in a long time.

Everything seems to be fine, are you sure the power supply is on? I know it sounds dumb but I swear I forgot to turn mine on today and it took a few minutes to figure out why it wouldn’t go.

Yeah its plugged in and everything and the red light under the motor sheild is on. What exactly does the reset button do? Just restart i assume? or take of the firmware and everything?

Reset is safe to hit. Firmware is not touched.

Red light under the shield comes on with usb power as well. If you disconnect the usb is the light still on?

Have you tried moving every axis?

unplug the power and usb, unplug all the motors except the z motor and plug it in to a different axis. power it all back up and see if that helps.

i disconnected the usb and the light was still on. i tried moving every axis before i unplugged everything and still nothing worked. then i unplugged it from the computer then turned the power off then took all the motors out except z and i plugged z into x and plugged the power and usb back up and then tried to move x and still nothing.

You are using my firmware correct?

Did you select the right com port in the settings in repetier? I Should be able to borrow a mac tomorrow to see if I see any differences, but everything seems good. You are showing a temperature, that usually means you have a good connection. Maybe power it off disconnect, remove the resistor, reconnect see if a max temp error happens to verify a real connection.

Yes i am using the firmware that came on the board that i purchased from you this is what it looks like when i pull up settings