Converted to series wiring - steppers shudder when homing

Hey folks,

Converted steppers to series wiring last night. I simply rewired the steppers according to Vicious1’s hand drawing on one of the other posts.

Normal moves seem good (without the router, just simulating a run) but homing causes the steppers to shudder like crazy (X and Y homing). In parallel this was not an issue. I haven’t changed any of the move speeds.

Do I need to tune the drivers? Something else I should check?

When going series you 1/2 the voltage (but maintain current)…so if running 12vdc you only get 6vdc to the motors…might look into getting a 24vdc system, so you get 1/2 the volts (12vdc) but maintain the current, which would mean a bunch more power in the steppers.

There are also these, which multiply the stepper drivers feeding from one driver…

Mine is wired in series with the default power supply and I have no power issues.

Do you home your X or Y axis at all @Barry? Did you have to change homing speeds when you wired in series? Or you made no changes?

That shuddering in my experience is a wiring issue. I have experience that a couple times. It for me (everytime) was a broken wire inside the drag chain and everytime it would flex at that point it would shudder like it was going to explode.

Yep, I home between every job. I didn’t change any settings when I swapped over to series. I really should check the voltage off the drivers, but they’re still set to what Ryan set them to. I’m agreeing with Jason, the stuttering sounds like a wiring issue. One thing I can think to check before going over the cables, what do you have your rapid feed rate set to?

Well, normal moves are perfectly fine. Just homing it doesn’t like. Doesn’t sound like wiring to me ? Not sure what the rapid feed rate is but is unchanged from when I had it in parallel.

Can you jog from the home position to max then back to home without issue?

Absolutely. Full movement in all directions jogging or running a job. Only homing seems to overload the steppers. Either speed or driver settings. Haven’t changed the speeds from when it was parallel.

What is your homing speed set to?

Home usually runs at the rapid feed rate. Jogging can, but usually runs at the last cut feed rate.

I’m not at home at the moment but I will check the rapid feed rate tonight. But like I said. Unchanged from parallel. What are your rapid feed rates set to ?

In the firmware there is a homing_feedrate and default_max_feedrate in configuration.h are those not homing and job speed defaults

It also depends on where the command came from lcd or repetier.

I see what your saying, worked before, the part we are latching onto is the homing feed rate is different and it seems to be the issue. if you are homing at max feedrate series can suffer. This is the reason I went with parallel from the beggining, at fast speeds parallel is better. but at slow speeds parallel is better.

Y chose cutting speed performance boost trading off high speed performance when in series. the fix should be to chnage your homing rates, slow them down a bit (in the next firmware update the lcd homing rates have been fixed, but don’t work right now).

@vicious1 any idea when the new firmware fix is coming to fix the LCD updating issue (to allow faster movements with laser)

The new bugfix seems to work well I can put it up for the adventurous types to try. I am still getting RC8 emails daily so I am cautious about putting up a bad firmware.

I was using Repetier not the LCD. Will look at it tonight. What’s recommended for series?

I slower the better in my opinion so they dont slam into the end stops.

My steppers are going to happily remain in parallel, but I did turn down feed to 9000 mm/min, I think max default in the firmware was over 10000?
Silky smooth, but it still startles me when it zooms off on a G0… Might turn it down a tad more…

This is a 24x36 machine with 1" stainless rails, btw.

Ok, so the settings were originally set to 150 mm/m in the configuration.h file of RC7. Worked fine in parallel. Set it to 90 mm/m and it works good in series. Haven’t touched the pololus yet. May try that next and see what it’s at. But it’s working for now.