Cramer’s MP3DP

I can never win when it comes to flashing firmware…

[attachment file=“Firmware Update.txt”]

Firmware-Update.txt (764 KB)

I think you need to remove u8glib from the libraries folder, but that internal compiler error is strange…

That says arduino 1.8.8, you need 1.9

I missed that part about using the beta version. When I try to move any of the AXIS it seems like they need more power.

[attachment file=“2018-12-26 11.27.15.jpg”]


I am not seeing what board you have but the ulimachine boards have digipots in the firmware (or LCD adjustments) or regular will need manual adjustments.

I’m using the Mini Rambo.

Current can be adjusted with the LCD.

11:29:37.278 : echo:Stepper motor currents:
11:29:37.278 : echo: M907 X900 Z900 E900

What is the range or a good place to start?

That should be fine for a printer. What makes you think they aren’t strong enough?

Your steppers will run best at 85% max rated or lower. I have never needed more than what is set stock for the printer. That is why I asked what you meant by “Seems to need more”? Are your steppers cold and not moving? If the steppers are warm, slightly above room temp after 20 minutes of continuous use, you should be close enough to the right current.

If they are as cold as those granite slabs at cold stone, then check your thermostat. If they are hot enough to melt through the floor then you might have thermite motors instead of regular ones. It’s a sliding scale.

What type of connector is used on the mini Rambo for the endstops? Dupont 1x3? These don’t actually have a clip to hold them in. I tried to do this with Dupont 1x1 but they just fall out. Argh!

I run the steppers just hot enough to cook bacon…

The connectors are Molex connectors with a latch. Note, they use different inserts than the dupont connectors.

On these end stops, do I use both outside pins? Looks like the two outside pins are Common and NC. When the end stops are not set open, if I issue the M119 command it shows them all triggered.

Correct for the MP3DP wire the endstops NC, and when not triggered M119 should say open.

I seem to have the opposite when entering M119?

You sure you flashed the MP3DP firmware and not the MPCNC?


:frowning: My bad! I will try the correct firmware tomorrow.

I can finally go home!! All of the AXIS are working now.

The Z seems quite noisy though. Listen/see here


Maybe it is a rattle between the base and sides?