Crown test problems

Hi all,

I’m not able to get a decent crown test out of my MPCNC. I’ve linked the two versions below. What’s wrong to what I see:

  • The circle seems rather oval to me
  • The start and end points don't line up
  • The cross bottom and top are assymetrical
the picture with measurements was done on a ramps 1.4 board with a4988 drivers on 1/16 microstepping, the picture with the double crown was done on a MKS GEN L with a4988 drivers using the same firmware. I've halved the steps per mm value from the one on the MPCNC github, but that's about it. What I've tried:
  • Increasing belt tension
  • Increasing driver vref
  • Using a different mainboard which I know has functional electronics (out of my 3d printer)
  • Using a permanent marker instead of a pen to rule out any springiness in the mount
All motors have enough holding torque once powered up. Somehow I think that I end up losing steps (doesn't sound like it though) or "distance" in the return trip. I've plotted some squares but these come out about right (except for the 2mm in X that is lost).

Anybody any idea on how to solve this, or what I’ve done wrong?

Kind regards,

It doesn’t look like skipped steps. Since it does look normal on the whole, and just small features are wonky.

What is the pen mount? Is it Ryan’s? Is there a lot of pressure on the pen?

Are your pulley set screws tight on the motors?

Definitely not a normal crown. Is this Ryan’s gcode or yours?

1 Like

Thanks for the reply!

I’ve thought about it all day, and this could well be the cause. I checked all the screws as soon as I could, but they were fastened correctly.

But I think I’ve found the issue, a wire to the steppers doesn’t work correctly (even though I’ve checked them all for continuity) but I think of one of the steppers only one coil got powered. Is it a bad crimp or something? I don’t know.

When I found the time to crimp a new wire I’ll use it and let you know the results!

And by the way, I am using Ryan’s gcode and pen mount.

Thanks, just you replying gave me the courage to keep on debugging!



Solved it by using newly crimped connectors…