cut dimensions not equal to drawing Dimensions

1)bought everything from Vicious.
No changes to the flash or firmware that I know of.
2) no end stops
3)running on a PC
4) images attached
I’m having a problem getting the X, Y, Z, movements to match up to what the G-code is asking for. It’s not only G-code though, I manually (estlcam controller) move the cutter X or Y 10mm and the actual movement is appx. 17mm. move the cutter 10mm Z and the actual depth is 3.5MM. See images below. I drew a box and hole in Freecad that was 60mm SQ. with a 12.5R hole and imported it into Estlcam. It looks correct in the software. the G-code has the correct movement distances but the actual cut size is 95.25mm sq x 38.1mm hole 3-5 mm deep. Could I have set something up wrong? is there a setting I needed to change?
Any help would be appreciated.
Attached are images of the requested movements of 10mm deep and long. My settings for estlcam, images of my machine, boards and the code and dfx file. (534 Bytes)

attached images.

screencutimage.pdf (2.81 MB)

screenshot1.pdf (2.9 MB)

cutdepth.pdf (1.14 MB)

Have you tried using your machine with the marlin firmware, and repetier. Do the manual movements work correctly then?

You might want to look through the estlcam thread the correct settings have been listed a few times. I use marlin so that’s as far as I can get you.

images loaded

cutlength.pdf (1.13 MB)

boards.pdf (1.61 MB)

your settings are not even close, have a look through the estlcam thread. I have the settings posted in the second post, and different settings are listed towards the end of the thread. You need to pull jumpers as well.

I have not been able to get repet. to work at all. no the manual movements are not accurate either. but the only thing i have to go on is the controller in estlcam. It’s the only software that I know that makes my machine move.

The instructions are all setup to use repetier. Estlcam as the controller is not advised unless you have some experience with all the firmware and software.

I will walk thru the instructions again. I could “connect” with rep.but couldn’t get commands to execute. They would pile up in the command pending /idle field and eventually flush. I found the estlcam thread and will have a look and have a go at it again this weekend. thanks for your help.


check the “Distance per revolution” settings.

Easy way to adjust:

  • Make the axis move 100mm.
  • Measure how far it actually moves.
  • If it moved e.g. 170mm divide 170 / 100 = 1.7
  • Then multiply the "Distance per revolution" of this axis by this value.


I am still not able to use Repeater at all. I am however, with guidance from Christian Knuell, able to use Estlcam to accurately control my machine. I will need to work thru Marlin and rep. when i get my 3dprint head installed. Another problem for another day. Thanks for your help.