Does this mean I have an issue with my gcode?

My MPCNC is moving, but stops shortly after startup and the stepper motors have a low hum to them. When I click “stop” in Repetier it won’t stop the humming so I have to disconnect the power. Is it an issue with my gcode?

Here’s a video of what it’s doing:

The steppers stay energized for a while to hold there position. You can release them with an ending gcode line, the button in repetier or just wait and they will release. It is very normal. That way the spindle doesn’t fall back onto your work and ruin it.

First off, great choice of brand. Next, the motors sound fine to me I think they are just struggling because you have the speed set so slow. You should have your router running because I think what you are hearing is the machine trying to push the bit into the MDF.

As for your settings, with MDF its very soft and cuts easy. You can plunge more than 1mm at a time, that is nothing. If you are just trying to play it safe then I would plunge at minimum 3mm if not 5mm.

Also, your angle of entry for the bit is set to 15 degrees. This means it will start at the surface and then enter the work at a 15 degree angle which is really shallow. I can see the point on your bit in the video, you can plunge 90 degrees (straight down) with that bit with no issue.

Your forward speed is a serious crawl at .3mm/sec. That means it will only travel forward 1mm every 3+ secs. That is why it says it is going to take 3 hours to cut something that should take like 10-15 mins. Change your forward speed to 5mm/sec.

I am being very conservative with these numbers so when it takes off you don’t flip out, lol.

You will likely be able to go faster than this with your machine. I am not sure of your actual machine size but this is a good start.

And this time, turn your router on before you start the program so you don’t break your bit off.

Good luck! It will be fine! You got this!

1 Like

Thanks guys it’s cutting now! If I wanted to cut something harder like plywood or a 2x4(since I have a ton of it laying around) do I just need to slow the speed down?


That is a harder question than you think. Recently I have been looking at it a little differently. I find if a little easier to just go shallower per pass on more dense materials. I keep my speeds at about 8-12mm/s and vary the depth first. I can go almost 10mm per pass on pine I go about 5mm in MDF or IPE. The only time I vary that speed is say I want to cut through a 6mm think piece of MDF. Instead of making two 3mm passes, I will make 1 slower 6mm pass. I think I got that into words correctly.

Some prefer to speed up the machine, I prefer to slow it down and go deeper. Technically this makes your endmills last longer as well.

I understand. I ran into an issue. I printed off the Apple logo and it printed fine until it got to the leaf at the top and it just drilled a hole as seen in the pic. From the time it stopped cutting the apple until it started drilling the hole it went VERY VERY slow

You have to attach your gcode, and give more details. Way too many things that can effect this.

I just noticed it saved it as a .nc file and not a .gcode. How do I save it as a .gcode? It used to do it automatically. On the drop down menu it only gives me the option for .nc. Can I just end the file name with .gcode?

Yeah, it should be a text file and you can just change it.

If you’re using Estlcam, the “setup” and then “program settings” menu will give you a screen where you can change it.

1 Like

4th picture on this page.

Odd, I did all of that during setup. gcode attached.

apple.gcode (7.06 KB)

You need to go through it all again, you are missing a bunch of settings, 5th picture down for sure isn’t done. That is the issue but you need to double check everything else as well.

Ok thanks. What would cause all these settings to be reset to default? I did everything on that page before I started cutting and now it’s all gone.

I don’t see any way to reset the settings, so perhaps you just had a glitch or crash or something after you set them and they weren’t really saved?

Possibly. Well it set everything back up and have it saved as a .gcode. I’ll cut it again tomorrow and hopefully will have better luck. Thanks everyone.

Okay so I tried cutting the apple logo again. It cut the apple fine but not as deep, then it made a second pass which it didn’t do that in any of the other tests. It got about half way done with the second pass and quit. It didn’t cut the leaf either. I looked on Repetier and it just showed the apple itself, but when I loaded the gcode up it had the apple and leaf.

[attachment file=54112]

apple-1.gcode (44.3 KB)

Your settings still are not correct. You have a feedrate of 0.083mm/s that should have taken about 2 days to cut.

Screen shot of your entire estlcam screen with the apple on it will help I think. But again, I would go through the settings. most look correct now other than there is no way it is. Check every setting shown in my screenshots, not just the highlighted ones.

I’ll give the settings another look.[attachment file=54116]

Have another look at the 4th picture in my settings. Marlin is set to mm/m for the output. To be safe triple check the rest of the settings.

It is advisable to stay under 8mm/s for the z plunge with a typical value more like 2-5mm/s.

Alright so it’s looking better, but it made one pass, then a second, then went on to a third. Should it be making this many passes? Attached is the current gcode.

[attachment file=54159]

ap6ple.gcode (26.6 KB)