Dual End Stop Firmware Update, RAMBo 1.4, Not uploading

I have (had) a working MPCNC with a RAMBo 1.4 board that I purchased from V1 with the preinstalled firmware that I bought back in 2018.
I am wanting to update the firmware for dual end stops and have been following the instructions on the V1 site for firmware updates for the RAMBo board (https://www.v1engineering.com/marlin-firmware/).
I am using the Arduino interface to try to update the Marlin firmware, the Arduino link I also got from the V1 firmware page.
The installation gets to the point where it is uploading the firmware then I get an upload error
I know I did something wrong but just not sure what. I did follow the instructions on the V1 site as they are indicated.
Any help would be greatly appreciated.

“Error compiling for board RAMBo”

avr-gcc: error: CreateProcess: No such file or directory
Multiple libraries were found for “U8glib.h”
Used: C:\Users\tlowr\OneDrive\Documents\Arduino\libraries\U8glib
Not used: C:\Users\tlowr\AppData\Local\Arduino15\packages\rambo\hardware\avr\1.0.1\libraries\U8glib
exit status 1
Error compiling for board RAMBo.

That error looks like you’re missing a particular U8glib library. I’ve seen instructions for adding it on these forums, but you might want to rethink your process. Relatively recently the paths and number of folders in Marlin have led to the compile line getting too long for the Arduino to compile in a Windows environment. PlatformIO is the new tool set that gets around this limitation if you need to compile your own firmware due to a unique set of parameters.

In addition, there’s a new process where @jeffeb3 and @anttix automatically build the software for many of the boards. You may not need to do your own compiling any more, just upload an already built hex file. I’m not sure whether the instructions have been updated to reflect this. I’m not using a Rambo myself or I’d try and provide better detail on the process to follow.

This problem is common on the forum, and contrary to the error, it has nothing to do with the U8glib.h file. The issue is related to command lines becoming too long. Jeff’s response in this post describes solutions: Dual End Stop Rambo 1.4a board Firmware issue

I ran into this problem and ended up building the release with platformio as my solution.

I have to jump in and disagree with both of you, and even my previous self :slight_smile:.

The key error is the CreateProcess error. To fix that, grab the firmware from the MarlinBuilder releases instead. In that firmware, we deleted a bunch of files you don’t need, and the result is a command line that is small enough to build in windows, with arduino. The allted/Marlin firmwares don’t have that fix and have been deprecated.

If allted/Marlin is depreciated, maybe Ryan (or whoever has permission) can fix the link on the Dual Endstops page to point to the MarlinBuilder releases page. This problem has popped up a number of times, and that link is the likely way they are finding allted/Marlin firmware to download.

3 Likes

Ok, I am looking to be able to use dual end stops with a RAMBo 1.4 board
If I was to download the correct file (appears to be “V1CNC_Rambo_Dual-2.0.7.2-src.zip”) from the link you are providing will it correctly upload ?
Also, if I get the file to upload correctly is there going to be any editing of some form of code or something similar that will have to be modified ?
I like to learn new stuff but this is getting pretty deep and I don’t want to screw up a system that is currently working WO dual end stops

Thanks again for all the support help, it is greatly appreciated

I flashed the same board awhile back for the same reason. It worked for me without modifications. However, I did go back and make one change. In the file Configuration.h in the Marlin folder you may want to modify these two lines:

// The size of the print bed
#define X_BED_SIZE 200
#define Y_BED_SIZE 200

These two lines should be set to the working area in mm of your MPCNC. If you don’t modify these lines, your router will have to be within 200 mm of the home position for your machine to home. If you are outside of this 200mm area, the router will start to home and then quit after it has traveled 200mm. These two lines can be modified by any text editor including notepad.

You shouldn’t have to edit anything. The instructions should be fine and you should end up with a dual endstop version.

Thanks for finding it.

I got the firmware updated and the system appears to be working correctly under manual control.
I would like to verify the end stops are signaling correctly and I will have to reset my work area size.
What software shall I use to view the end stop status
I know Robert said I can use a text editor to edit the bed size, will this have to be reflashed like the firmware was ?

Thanks again

I’m not aware of any way to set the bed size via g-code, so I believe you are stuck re-flashing the firmware or living with the 200 x 200 limitation. If you did not already figure it out, and M119 gets the states, but you will have to use something like Repetier-Host to receive the information.

Ok, I’ll reflash it and change the bed size as needed.
Where do I add the M119 statement
Sorry for all the questions

You need something attached to your Rambo board that can send g-code and receive status information back. I use Repeiter-Host on my laptop which has a USB connection to the Rambo board. In Repetier-Host, I first connect to the Rambo board using the Connect button in the upper left. Then I select the Manual Control tab on the right towards the top. In this tab is a section call G-Code with an edit field and a Send button. You type the M119 into the edit box and hit Send. The information about your end stops will appear in the window below. If you haven’t already setup Repeiter-Host, Ryan provides some information here, and you can get Repeiter-Host here.

Ok, I thought I was able to do that with Repeiter, just was not sure how to issue the statement
Got it working and can see the end switch status now, cool
I have not used the PC to interface with the rambo but only a few times to initially get the system working
I use a USB card to do all my jobs.

Thanks again
With out you guys I would be lost !

FWIW, the bed size is not a big deal. You choose when to send the “home” commands and the 200mm is just the distance it is willing to travel before it thinks it made a mistake (because it thinks the size is 200mm. Just jog or push the gantry within 200mm (8") and send the home there. If you screw up, hit the reset button or toggle your power strip and home again. NBD.

3 Likes