Dual Endstop Rambo 1.4 E1/Y2 Motor Problems

Hi All !

Long time lurker and after 1+ years finally decided to build the MPCNC :slight_smile:

The build has gone smoothly up until the end.

Software & Specs:
Rambo 1.4 Board (bought from AliExpress)
Marlin 509D ( Confirmed via startup )
Repetier Host
Windows 10

The Problem:
The Y2 motor seems to be turning too fast ? And I don’t know what is causing it.


These are the connections on my RAMBO board.
X1, X2, Y1 and Z all function correctly

Video One
In this video, the left motor was wired into the E1 Port. I then cycled through various Y AXIS movements in repetier-host.

Going from 0.1mm through to 10mm.
Both of these motors should be travelling the same distance. The blue tape is used for reference point.

Video Two:
I then swapped the ports, so the right motor is now connected to E1 (Y2) and the left motor is connected to Y1.

Cycling through some manual control movements. Up to 50mm movements

The story
Upon the very first startup, the board worked well controlling it via Repetier Host with Manual Control.

I had wired all the motors the wrong polarity. I turned off the power and removed the USB connection and then flipped the polarity on all the motors.

This is when I first noticed the problems.

The X-Axis worked correctly but there was a problem with the Y-Axis it looked like it was moving too violently on one side.

After sleeping on it, I reflashed the firmware and it started working correctly again with manual control. Using the crown test gcode I was able to partially draw a crown and then the problem occured again halfway through the gcode.

After a couple days I reflashed and I was able to complete the crown test. However the problem has since returned. During one startup, before the problem happened again, both motors on the Y axis seemed to invert their direction. Up was no DOWN and down was now UP.

I have tried numerous motors and even swapped the X and Y axis motor pins. The E1 Header pins seem to not be functioning correctly.

All End stops are wired correctly and report Open and TRIGGERED respecitvely.

What have I tried?

Unplugging everything but the two motors
Reflashing firmware
Different USB port, different PC
Reinstalling repetier

I wasn’t able to edit your youtube links in a way that would make them work. Let’s assume that the g-code, Repetier-Host and the firmware are okay. That leaves the drivers, the wiring, and the steppers. You say you swapped the stepper, so that just leaves the drivers and the wiring:

I’m assuming you swapped the whole axis X1<->Y1, X2<->Y2. Did the problem stay with the Y motor or did it travel to the X motor? If it stayed with the Y motor, then it is likely a wiring problem. If it traveled to the X motor, then it is likely a driver problem. If it is a driver problem, I’m not sure what you can do since stepper drivers are hardwired to the Rambo board. You could go to a serial build of the MPCNC instead of a dual-endstop build.

Hi Robert, I swapped the whole axis and the problem persisted to the motor that was plugged into that Driver.

Just edited the video links, should be visible now!

I’m no expert on steppers, but to me, it looks like the micro-stepping is not getting set correctly on the bad driver. This is set in the firmware for the Rambo board, so if you are using the V1 firmware unmodified, it is very unlikely to be the firmware. That just leaves the driver. Something may be preventing the driver from being set to the right micro-stepping mode. I’m guessing a hardware failure of that driver, or a bad solder joint on one of the pins that communicate between the firmware and the driver. This is conjecture on my part.

I agree here.

We saw something similar with the archim boards. But I haven’t seen this on the rambo.

Can you send M351 in repetier and paste what that shows here?

You can also try an M502 to see if that fixes it. That should return every setting to the default from the firmware.

M502 did not solve the problem.

send: M351
recv: MS1|2|3 Pins X:11 Y:11 Z:11 E0:11 E1:11

send: M502
recv : Writing Digipot
recv: Digipot Written
recv : echo:Hardcoded Default Settings Loaded

send: M350
recv : MS1|2|3 Pins X:11 Y:11 Z:11 E0:11 E1:11

Output of

recv: echo: G21 ; Units in mm (mm)
recv : echo: M149 C ; Units in Celsius
recv : echo:; Steps per unit:
recv : echo: M92 X100.00 Y100.00 Z400.00 E100.00
recv : echo:; Maximum feedrates (units/s):
recv : echo: M203 X50.00 Y50.00 Z15.00 E25.00
recv : echo:; Maximum Acceleration (units/s2):
recv : echo: M201 X180.00 Y180.00 Z80.00 E180.00
recv : echo:; Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>
recv : echo: M204 P180.00 R3000.00 T180.00
recv : echo:; Advanced: B<min_segment_time_us> S<min_feedrate> T<min_travel_feedrate> J<junc_dev>
recv : echo: M205 B20000.00 S0.00 T0.00 J0.04
recv : echo:; Home offset:
recv : echo: M206 X0.00 Y0.00 Z0.00
recv : echo:; Endstop adjustment:
recv : echo: M666 X0.00
recv : Y0.00
recv : echo:; Stepper motor currents:
recv : echo: M907 X138 Y138 Z138 E138 ?138ok

Besides the microstepping, I can’t think of a way for Y2 to be any different speed than Y1. The rest of the settings are always mirrored.

I just noticed it was a clone board from ali express. There were some that had the motor wires swapped around. They would be wired abab instead of aabb. We saw this on some cloned mini rambos. I wonder if that would look like that. Otherwise, I think it is a bad board. The microstepping pins are all just traces, I believe. So if something was missoldered, it would be very tiny.

I suppose it is possible one of the ms pins is wired to a different spot on the micrcontroller. Do you have a skematic of the clone board?

This is the exact listing I bought the board from

RAMBo 1.4 Motherboard RAMBo V1.4 board MEGA And Stepper Drivers All On One Integ

It is certainly weird because it has worked twice for a brief period of time. So I feel like something is amiss somewhere on the board.

I might have to dust off my oscilloscope … Not sure what I would be looking for though.

Sigh… I got out the scope and did differential voltage measurements on the Vin power rail (for a test) and the E1/Y2 pin out … and it looked ok.

Now none of the steppers in any of the ports work.

Uh oh. Did you check the fuses? Is the power supply ok?

Had a look this morning with fresh eyes.

Fuses are good and power supply is good. Can still reflash etc but yeah, none of the motor drivers even work anymore. Very weird !

Edit: Awkwawrd spoke to soon and my coffee just kicked in. Wire was loose. Back to the original problem with E1 driver though.

No Luck. I think I will just buy another Rambo board

I might do something crazy and try to reflow the board

You could build your machine in a serial configuration. If you install calibrated hard stops, you can do the same things that you would do with dual end stops.

1 Like

Hello everyone!!

I have some good news! :slight_smile:

I managed to get a copy of the PCB schematics and did some investigating…

I grabbed the strongest pair of reading glasses I could find and got working.

I heated up the driver chip with a soldering iron very very carefully on the ms1 and ms2 pins. I then got a scribing tool and scrapped between all the pins.


It’s been working reliably since!!!

I tried to probe continuity during debugging but it was hard with the pins being so small. I suspect the board either had a bad solder joint or something was shorting out the microstepping pins on the driver.


I am impressed. I have reworked some boards and I have a very high success rate for “interesting and fun”, but a very low success rate for “working”. :clap:

I think it was definitely beginners luck this time :laughing: