dxf. file to ESTLCAM - Z axis

Can anyone point me in the right direction. I am using Autodesk for my 2D drawing I save them in a dxf. file, Open them on Estlcam and convert to g code. I save the g code program on the SD card. Inset the SD card in LCD and ready to run. I am having issues with some g code flipping the Z axis. Not all of the dxf. files converted are flipped and they don’t show up like that on the Preview in Estlcam. The Crown test came out good and I have run several sample cuts with the router in soft wood using the g code from Autodesk.

I flipped the wire on the Z axis on the mini Rambo the first time but what a pain. I am looking in the CNC program setting for Reverse Z-Axis every time to make sure it was not checked my mistake.

Still puzzled.






I do not know why some of the

You can get those symptoms if you ever try to move the Z axis a bit too fast. Typically that’s when your settings aren’t all set, which allows an attempted movement of the Z at X or Y speeds.


Thanks Bill I did check the speed in setting and they were at default. I set them to recommended for the crown test and ran ok. I work out of town a lot and only have a few hours or a Saturday to enjoy my new hobby.

I have a new issue and I’m not sure what happened. I ran a few test boxes in wood with the router that night after resetting the feed rate speed for X,Y & Z and cut a few nice mini boxes.

Today July 14 I plugged in the MPCNC and ran a test box in the air from the SD card to make sure all is well. Nope the CNC is acting like the motors are apposing and they just rattle. Do I have a corrupt Mini-Rambo, LCD, SD Card or G-code from the Estlcam?

Run my crown gcode to verify. That is one known good code. At this point there is no other way to narrow it down.

1 Like

Ryan I just tried the Crown with same results. The program starts with first step to run and then the steppers just rattle. I can run X,X & Z with manual commands from the LCD.

I just created a simple box in in CAD sent the dxf. to Estlcam then onto my SD card in and it does the same thing. I want to figure this out, what happened it was working so well.

So only use this file until it works. Anything else introduces opportunities for error.

I assume you used an LCD? Run my gcode from repetier.

I am getting the feeling you accidentally flashed your board with Estlcam…it is far to easy to do.

Sounds like one (or more) of the stepper connections came loose. Check the wires and connections between the steppers and the mini-Rambo.

I downloaded the free version of repetier. I am trying to use repetier and I don’t find it very user friendly.

How do you get the crown gcode onto repetier. Are there instruction

Either click the square icon that has a plus sign in it, or File, Load.

Ryan thanks for the help.

I ran the crown gcode from the repetier with the same results. The manual commands work fine but no gcode. Can the Rambo board be cleared and reflashed?

What does this mean? When you use repetier and tell it to move the machine it runs fine, and when you “play” the gcode it makes funky noises?

When you tell it to move 50mm with repetier exactly how far does it go on all three axis?

The X,Y & Z all move with the repetier manual controls. I just measured the 50mm in x & y and its accurate and also the 10mm Z in is good.

I downloaded a new Crown dxf. for the latest test run converted it to gcode loaded it in the repetier and hit start print. Yo can see X & Z axis both move at the start, then all axis stop moving and the motors just humming away (Locked up). I see the gcode operating in the logs below but no movement from the stepper motors.

Use my crown gcode to eliminate the largest sources of errors.

1 Like

Thanks Ryan

This was a successful crown print. So where do I go from here?


That just means you need to triple check all your cam settings. Your speeds are off choking your drivers, could be a number of reasons but if you just go through ever box on my estlcam basics you will find the error. I am better you didn’t catch the export to mm/min.