End stops show triggered but not stopping Stepper

I have installed the Dual End firmware.
The steppers are working in the correct direction.
The End stops show triggered when they are pressed using command M119
But when the steppers run into the switches. It doesn’t make them stop.
If I make the stepper move and hit the End stop switch. They keep moving.
I am using the Dual End stop firmware from V1.
What am I missing here.
My goal is for the Auto Squaring.
For now Im just trying to get the End stops to work.

They only trigger during homing.

if i tell it to home. the stepper will try to push past the switches and not stop.

Sounds like the endstop and the stepper do not match sides, test with m119. That usually happens when x1 is plugged into x2’s end stop and vise versa.

I have Y axis working.
The X axis wont stop when they hit the switches
I have tried switching the X min and max back and forth.
I have set it to home and manually hit the switches while it is moving. I never stops.
I used M119 command.
It shows them being triggered.
Y axis switches works great.
Am I missing something or is something the logic value not right?

They should only say triggered when depressed, so wire them the other way if that is not the case.

They show triggered when the switches are pressed.
They are wired just like the Y switches.
If I move the X switches to the Y plug locations.
And press them while it is homing, They work. Just to see if its the switches or the board.

It act like board doesn’t know what to do when the X min and X max are triggered or not.

tried to wire X switch from NO to NC.
Still doesn’t stop the stepper when homing

Are you using Ryan’s kit? What board?

If you have a multimeter, test that the end stop extension wires have good crimps on the spade connectors.

I do this by probing the metal tab sticking out of the dupont (black plastic connector end) and the spade that hooks to the end stop itself.

I made myself a diagram of the rambo 1.4 board in case I ever had to move things around.

[attachment file=“Rambo14 DUAL help fixed.jpg”]

Ramp 1.4 from V1

Everything is plugged in like it is supposed to be.

As far as i can tell it has the latest version firm ware for Dual Endstops.

I have tried 2 different boards. They both do the same exact thing.

 

I have checked all of the connections.

Everything is tight and snug.

Multi meter has consistant readings for all of the wire connections.

There has to be some setting that is off for the X end stops.

I have moved steppers and switches around.

I have tried 2 different Ramps and Audrino boards. I have tried different drivers.

M119 shows the switches getting triggered.

Something is not telling the firmware to stop.

On Y endstops. I have a Y min and Y1 min. (This information comes off the M119 output.)

On X endstops. I have a X min and Y1 max. (This information comes off the M119 output.)

 

Is Y1 max right?

Sorry,

Both Y and Y1 at min.

Y work

X has X and X1. a min and max

I tried switching them around. But get the same results.

I will have to flash a ramps and double check. I just tested this last week when I updated everything I swear it worked perfect, maybe I missed it.

Hopefully I got the right one.

Does your code have a version in the title or inside one of the files?

Just downloaded, flashed and plugged in a ramps…

[attachment file=66714]

Why does my X have a min and a max.

Yours just shows a min for both.

I’m pulling my hair out.

https://github.com/Allted/Marlin/archive/MPCNC_Ramps_T8_16T_LCD_32step_DualEndstop.zip

Flashed with Arduino 1.9?

yes I did do that. it wont load with the older version.

Is there some kind of signature of your in the coding saying what version it is or your name.

I go to Gethub and download Marlin

This is what I am grabbing off of Gethub

 

 

Click the link I posted, flash it as is and see if that changes anything. I can not possibly see how you are getting different settings doing it that way. Make sure you get a successful flash, and show me a screen shot of the exact repetier output like mine (use the windows snipping tool).