Endstop Woes. [SOLVED]

1) Did you buy everything from here?
Yes, I purchased everything from you.

b)What board do you have?
Rambo

c)What firmware is on it or which did you buy it with?
It is as shipped from you. Dual Firmware and wiring kit was the one I selected.

2) Are you using end stops?
Yep, kinda the point :wink:
a)If so how are they wired, NC or NO.
NC, at first I didn’t notice the X1 Y1 and X2 Y2 were offset (top row of endstop pins use 2 and 3 in the connector, bottom row use 1 and 2) this was corrected and still no change in operation.

  1. Mac or PC (windows xp, 7, 8, 10?), linux?
    PC - Windows 10 - repetier host

  2. Include a picture so obvious errors might be spotted.
    Here you see I have the correct wiring for the end stop switch.
    [attachment file=66175]
    [attachment file=66172]

Overall view of the Machine.
[attachment file=66173]

Ok, So i’m fairly decent with troubleshooting and searching, and I probably already have my answer but I want someone smarter than me to give me a sanity check. I assembled everything over this weekend, I was able to move all the axis (x, y, z) but only the Z would go both directions. I attributed this to the fact that I could not set “Zero” on X and Y from the LCD. I got a little ahead of myself and loaded ryans test crown - 12mm/s file onto a SD card and attempted to “Air cut” (all axis were in approximate middle of their total travels so I didn’t need to worry about crashing anything. Well, I could tell that any X+ and Y+ worked, but as you can imagine, it just kind of traveled on until I stopped the machine because it would have crashed. It never performed any X- or Y- movements.

Onto testing.
So I connected with repetier host and moved the machine to a safe spot manually (disabled power to steppers, moved machine back to mid table)
I did 10+ X. Moved 10mm.
I did 10- X. Nothing.

Same with the Y axis.

Z axis functions normally (Inverted for my preferences in repetier host… Up in repetier host moves the Z down and Down in RH moves Z up lol) as far as I can tell anyway.

Things I have done:
Checked M119
[attachment file=66174]
Ok, Triggered. This tells me open circuit because if I followed the directions it should be closed (Wire the switches in NC). Ran it again with x1 endstop depressed. No change. Checked each switch in this fashion. No change on the 30 bazillion (felt like) times I held a switch and issued M119.

I have verified each Endstop switch with a multimeter on the continuity setting (the one that beeps when you touch probes together)

Each switch beeps when the common terminal and NC are touched. Each switch also ceases beeping when I depress the lever. I believe this means the switches themselves are working as intended.
Next up, I checked each Stepper extension cable (The 5 white cables that came with my kit) Each side of the 2-pin part of the harness has continuity (unplugged from what i’m guessing is Ultimaker’s end stop switch harness kit?)

Now, onto this pesky Endstop wiring kit… NONE of the cables tested good. It looks like there is bad crimps but I don’t want to cut them to find out which crimp is bad. (Dupont or spade terminal)

After typing this post (long) out… I feel like I need to make new extension harnesses to replace the ones with bad crimps, and that would get me up and going, but the whole point of buying a kit was to be mostly plug and play, off and running without having to do a ton of custom wiring.

Ryan, Would it be in the realm of possibilities to get a new “ulti” endstop kit? (One that you’ve verified has good crimps?) I’d gladly send you the faulty ones back (I don’t know if you can get a vendor credit due to faulty crimps… but eh, worth a shot right?)

Was hoping to draw in the air tonight, and my DW660 gets here next week.

Charles

TLDR: Bad crimps, verified with multimeter, will “Triggered” end stops prevent negative x and y axis movement?

Edit: Marked solved because replacing the spade connectors worked, I can now automagically home my machine.

 

SO… I just jumpered the end stops for now (on the board itself)

I was able to move all axis. I zip tied a carpenters pencil to the tool mount (ghetto!) and ran the Crown.

Given that the pencil moved up and down and I was drawing on cardboard, I’m pleased with what came out (on the second run anyway, first run I discovered I needed to flip my Z motor plug lol)

So I guess my only question that remains from my OP is this

“Ryan, Would it be in the realm of possibilities to get a new “ulti” endstop kit? (One that you’ve verified has good crimps?) I’d gladly send you the faulty ones back (I don’t know if you can get a vendor credit due to faulty crimps… but eh, worth a shot right?)”

 

All of them? Yikes. Can you tell which end the crimp is bad on, I want to email them right away, there have been a few reports of random ones not working but never an entire set.

If the issue is not easily fixed on your end I can send another set.

This would have 100% popped a ramps board, and I thought this board as well. High five Ultimachine, best boards ever! I love learning new good stuff like this. Sorry it had to come out of your troubleshooting but dang, if we were using ramps you would be buying another new board set.

1 Like

The crimp is bad on the spade side, don’t worry about sending another set, I’ve already mangled a few of the connections to test if the wires themselves were good, and they were. I’ll purchase some new spades and just replace the ends. The dupont side of things was fine in my testing :slight_smile:

I placed an order last night for some goodies for the machine now that I know it’ll work!

I’ll be on the road a couple days this week and by the time I get back I should have my Dw660, a pen/drag knife mount/drag knife, and 20’ of sleeving so I can clean up the wiring :smiley:

Thank you for having a place for me to vent, I ended up troubleshooting everything myself but it helped to have somewhere to type everything out, and hopefully I was informative enough that someone else might be able to help themselves too!

 

Ubiquitous Crown Test with a poorly secured carpenters pencil on uneven stock… ( warped cardboard!)

[attachment file=66214]

And the pic of the way out of round pulley. I already ordered a replacement from you :smiley:

[attachment file=66213]

Cool, I will email them this morning. That is what I had heard in the past, spade crimp.

 

Sorry I wasn’t more available this weekend. I seriously just had to take a few days to not look at the machines. The new LowRider almost burnt me out.

That pulley is way bad, no way. I will refund that for sure. Sorry, I have heard out of round pulley before and that was not what was shipped back. My bad. That looks like a 6mm shaft hole.

No worries, I’m pretty relaxed, everyone needs a break. I spent friday and saturday laying block for my house… Needless to say I wasn’t moving very fast yesterday.

[attachment file=66222]

Yeah, the pulley has quite a bit of wobble to it. I think that’s where some of my “jumping” is coming from right now.

Anyways, glad I was helpful in testing a potentially expensive lesson on the ulti boards… I do like them a lot compared to all the ramps boards i’ve messed with in the past.

That is a large project!!!

Marked as solved, replacing the spades fixed the issue. Changed the out of round pulley while I was at it.

Got my router and surfacing bit in today :smiley: Stay tuned i’ll make a thread in the build section soon :slight_smile:

1 Like