Error compiling dual endstop firmware

I am not able to compile the dual endstop firmware. I get a - missing binary operator before token “(”
see the attached link to pastebin for complete error.

Anyone got a fix?

I am using a MKS 1.4 if that matters

I believe you need the 1.9 IDE to compile that.

After trying with 1.9 beta i still get an error and not able to compile the firmware.


You used one of my pre-configured firmware, with no changes? That says it is missing a lot of things, some of which we do not even use.

Also you are using a dual firmware on a board that has not had its pins file modified.

Yes, the one i found here. The only thing I changed was wich drivers i use(DRV8825) max size of bed, and type of lcd display.
Tried to change to RAMPS 1.4, but still getting the same error. Am I not using the right firmware?

I am not sure about that board at all.

Try the non-dual version first.

The non dual works fine, but I feel the steppers are getting to hot. To hot to touch. Even if I lower my current settings on the driver. If I lower the current to much, i loose steps. They are wired in series.
So i thought one stepper per driver was better. That’s why I want to try the dual endstop option.

You are using a board I have never touched, seen, or tested. I am trying to help but please understand this has to happen one step at a time.

What drivers and steppers are you using?

The drivers i use are DRV8825, steppers are 17HS4401. Board are Mks gen 1.4, but I also get the same error when i try to compile the firmware for the RAMPS 1.4

Using Arduino IDE 1.9 beta

The non-dual firmware works, that means everything is fine. The dual firmware has pin edit that are board specific. If you want to use the dual you need to make the pin edits for your board.

I think you should adjust your drivers and just use series for a while. Stepper power is typically never and issue. You mention heat that is a driver setting issue, you do not mention anything that points to stepper power issue.