Error:Line Number is not Last Line Number+1

Resend: -65424
Error:Line Number is not Last Line Number+1, Last Line: -65425
[ERROR] Error:Line Number is not Last Line Number+1, Last Line: -65425

I’m following the Estl-Basics instructions but I keep having this issue.

When I try to run the gcode with repetier or pronterface I get the above error. I tried printing from the display but the board resets when it hits this part.

I received my board from Vicious1. I reflashed it according to the instructions with his marlin firmware.

This starts immediately when I begin the print.

Beginning of my GCODE:

;Project 0059
;Created by Estlcam version 9 build 9.018
;Machining time about 00:00:35 hours

M03 S24000
G00 X0.0000 Y0.0000 Z0.0000
G00 Z2.0000

;No. 1: Engraving 1
G00 X52.1499 Y61.8729
G00 Z0.5000
G01 Z-1.0000 F180 S24000
G01 X52.0494 Y61.8693 F900
G01 X51.9488 Y61.8654
G01 X51.8483 Y61.8610
G01 X51.7478 Y61.8562
G01 X51.6473 Y61.8511
G01 X51.5468 Y61.8456
G01 X51.4463 Y61.8396
G01 X51.3459 Y61.8333
G01 X51.2455 Y61.8266
G01 X51.1451 Y61.8194
G01 X51.0448 Y61.8119
G01 X50.9445 Y61.8040
G01 X50.8442 Y61.7957
G01 X50.7439 Y61.7870
G01 X50.6437 Y61.7780
G01 X50.5435 Y61.7685
G01 X50.4434 Y61.7586
G01 X50.3433 Y61.7484
G01 X50.2432 Y61.7377
G01 X50.1432 Y61.7267
G01 X50.0432 Y61.7152
G01 X49.9433 Y61.7034
G01 X49.8434 Y61.6912
G01 X49.7436 Y61.6786
G01 X49.6438 Y61.6656
G01 X49.5440 Y61.6522
G01 X49.4444 Y61.6384
G01 X49.3447 Y61.6242
G01 X49.2452 Y61.6097
G01 X49.1456 Y61.5947
G01 X49.0462 Y61.5794
G01 X48.9468 Y61.5637
G01 X48.8475 Y61.5475
G01 X48.7482 Y61.5310
G01 X48.6490 Y61.5141
G01 X48.5499 Y61.4968

Reflashed it?

If you are using the RC8 firmware you need to update ESTLcam to the one he put out this morning. Have a look through the basics page as I just updated some settings.

Sorry for the confusion but things are about to get a lot easy and more reliable starting this morning!!!

Its starting to look like a bad usb cable problem.

Double check. If you are using RC8 the 2 lines with z moves in it will crash the arduino immediately.

I’m using MPCNC_RC8

That code is from the wrong version of estlcam. It will not work. Download the newest one from this morning.

I’m using this firmware on the Arduino:
I added the u8glib library for the screen.

Estlcam Version 9.0.18

OH!! So I need ESTLCAM 9.037 beta?

yes, the new beta and have a look through the basics page for the new settings.

SUCCESS!! mostly. I started over with the estlcam beta. The first time I ran the gcode with Repetier-Host I got errors:

Error:Line Number is not Last Line Number+1, Last Line: 9606690
Resend: 9606691

I was kind of dumb founded so I tried again and this time it moved my pen around and drew my thingy.

Something is still not right but I’m closer.

I tried again running the file through Estlcam. I loaded the gcode into Repetier-Host and started the print. It moved to the start and crashed with errors.

Error:No Line Number with checksum, Last Line:12
Error:Line Number is not Last Line Number+1, Last Line:12
Resend: 13

I reloaded the file in Repetier-host and hit print again. It printed this time no errors and returned the pen to the starting place. Perfect!

I’m still confused as to why it doesn’t work the first time.

Awww…I just noticed I have “Killed. Printed Halted Please reset on the display”

I’m up and running. I’m still having some odd disconnects and errors but I can successfully draw an object.