Estlcam f* up?

has anyone had the following issue with estlcam?

I set a fairly simple shape as a part, a rectangle 13cm x 6 cm. Using trochoidal milling I set the depth to 6mm. When I go to the LR2, I set the zero point using my touchplate like I always do.

However, when the LR2 starts working it only goes like 2mm deep instead of the 6mm.

Would this be a f* up of estlcam, or could something else be wrong?
Anyone some hints on troubleshooting this?

I´ve tried 3 clean files by now, and wasted 3 times some expensive acrylic :frowning:

Is the tool Z step depth only 2mm? If you let it run will it take 2 more passes?

Hi Tim,
Good question:) should have noted it in my question.
The depth per pass has been set to 6mm for the tool. The material is 5mm thick but set it to 6mm deep as my bed isnt’t level enough.

Can you post a picture of the tool setup window?


Also, have you made any changes recently since the last good run? Updated EstlCam, changed any other parameters, etc.

How thick is your bit setter?

Before you start scratching your head, are you using estlcam firmware, or just estlcam to create gcode?

All valid questions :slight_smile:

I am operating an LR2, using the SKR Pro and endstop FW (althoug not using them yet). I made a design in LibreCAD and use estlcam to create Gcode.

For Probing I use a separate script, that´s easier for my simple mind :relaxed:
As I often use this script I now it works (improvements will always be possible).

For this job I have set the tool to the following to cut acrylic;
I´ve made 2 test cuts before so I know these work (again: improvements will always be possible).

Between 2 jobs I´ve only changed 1 setting, that´s the plunge angle. According to my research a ramp would be best to use in case of acrylic, so I´ve had plunge angle also on 60° as a test, to see if this caused the issue.

This was the output preview;

I´ve tried two options for setting the depth as a test, to see if this caused the issue.
One test I´ve set the toolpath depth, in the other I set the overall cutting depth instead of toolpath depth.
(watch the starting point, this is the first time i´ve used it)

Now my Gcode knowledge isn´t there yet, however I believe the following indicates it should cut Z on 6mm DOC. No?
Schermafbeelding 2022-05-13 102033

So I start to believe it isn´t estlcam, but the SKR the causes the issue.
The only thing I can think of that might have triggered some error, is that I´ve set a starting point as I never did this before.
When the job starts it goes correctly to that starting point, but only roughly 2mm deep.

Yeah that gcode is dropping to -6. Does it move down to -6 when you jog there? Is your bit upcut or downcut? Have you tried running the operation without material to verify bit loads are not causing issues with z? Check your set screws on z?

1 Like

Thanks for thinking with me.
I have found the issue. You´re not going to believe it, but I used a new bit and it seems to be a hair smaller then what should be needed…

It seems that the bit got compressed (in to the bit holder) during touchpoint of the material, coming 4 mm short.

I feel like an idiot now, but at least I have found the issue. :slight_smile: