Estlcam - increase speed move to position?

Is there a way to speed up the “move to position” in Estlcam? When the bit is lifted to move the gantry to another position, it moves very slowly compared to the carve speed. It seems to be about 25% the speed I have for carving and pocketing.

1 Like

There is a spot where you specify the parameters of the move commands.

By default, Estlcam will assume that G0 (vs G1) move speeds are “rapids”, and don’t need to be told the feed rate, but Marlin doesn’t treat G0 differently from G1, and needs to be told the feed rate or else it will use the same as the last move command, which is typically the Z lift to the clearance plane.

To Fix:

  • Go to Setup | CNC Programs and then to “Coordinates” tab
  • Make sure that both “Enable” and “Repeat” are checked in the “F” column.
  • Optionally, enter a feed rate for the Rapids feed rate. (If you don’t, it will use the defined cut/plunge speeds for the tool.)

What this does is to tell Estlcam to include the “F” (Feed rate) in every move command, including the Rapids, so it will tell the machine to move at the proper speed with every move command, even if it hasn’t changed. This makes your CNC program a little bigger, but a little more controlled.

6 Likes