Estlcam not reading DXF

This is going to sound repetitive, but I can’t find my earlier post;

DXFs are not opening in Estlcam - I have exploded the layers, I have put them all in one layer, and saved it into DXF 2013 from my AutoCAD 2014 version. Something isn’t happening and I can’t recall what it is.

My file is set up in mm and I have attempted to open the DXF in both mm and inch. Ugh!

Have you tried object to path? Have you tried saving as svg and seeing how it turns out? Estlcam can open svgs, but with varying results…

I’m missing something - I thought I had it sorted, but time clears the short term memory and I have lost it.

Splines won’t get exploded - so I took the time to redraw my shapes and do it again, but nothing. Now I am shifting CAD rograms and trying to open both dwg and dxf in FreeCAD and F360 to see if I can get it hopping - but no joy. This is getting ridiculously frustrating. I’m about to pitch the whole thing!

I have no answer, but if you put the AutoCAD .dwg file as well as the .dxf file in a ZIP file and attach it to a post in the forum, I’ll see if I can find a pathway.

Well, I don’t know what AutoCAD is doing - but I imported that DXF into FreeCAD, did all the things needed to take the shapes and make them sketches then exported all the sketches into a new DXF and voila! It’s in Estlcam to get tool paths going. I’m done for the day! I’ll be doing most of my future drawings in FreeCAD from now on I think.

1 Like

Can we try?

@DuffyNW I know AutoCAD can export different versions. Did you try changing the export setting to an older DXF version?

I figured JeffB would like that I finally turned to FreeCAD!

I will post the files up in a bit. My hesitancy is that there is three lines/objects overlapping in a 2D file that makes the easy posting of the files a little difficult to understand up front without a load of explanation. So I’ve completed a work around and drove on. Sorry. I think I’d like to know what is holding Estlcam up from using my AutoCAD DXF, but right now production is overruling troubleshooting.