Estlcam / rep host issues

When I swap the LCD wires , the screen is only blue with no writing .

Where did you see user edit loaded ? On the LCD or on the pc

User script done is on the screen because I zeroed the machine

Unplug them both and swap them both. Not just one end. The ports use different wires, this is just a double check that there is not a single bad wire causing havok.

This, use the menu to initialize the eeprom, that will reset everything as I have intended.

I swapped the ribbons and i used a printer usb , same way it is cutting , same circle

i reset the eeprom and same issue . same cut ,

My material isn’t level but this is the code Jamie made @vicious1

1 Like

Okay then for some reason the crown file is still not working for you.

BUT…Your machine checks out!!!

Open the test crown file with a text editor and see if it looks normal, readable. I am guessing the file got messed up. It can happen if you open it with the wrong text editor and hit SAVE…don’t save from a text editor, they tend to add characters.

So the machine, board, lcd, works. now you can move to estlcam basics and try to make your own file.

I never opened any files , even the files i saved from aspire isnt cutting

I have no experience with aspire.

I highly highly highly suggest you stick with ESTLCAM for now. Use the free version. You can’t get a file to cut on your own, and I do not own aspire and can’t help.

If you use estlcam I/we can very easily help you. If you use aspire You are on your own except for a couple people that use it here, if they help you out.

Step one is the crown test file. It works and has been proven thousands of times over. It works so best to figure out what is happening for you between my file and your SD card that is making it not work.

1 Like

No need for that, my crown test file has that built in.

@vicious1 I am not sure you are understanding me , estlcam is not working with your crown file . the only file that worked is the file that Jamie made. I have no intentions for Jamie to make all my files for work. The machine is not connecting to rephost. even tho i changed the usb plug. I have estlcam version 9 and version 11. none is able to open your file.

I however was able to load files that i saved from inkscape. i followed your instructions with these files (12 different designs ) and all are not working . some are carving only left to right , some is making circles , some are lines … All these problems can not arise from a board that is working properly …

files from your site and even aspire files are not running the way they should . I did everything that everyone suggested and still I am unable to use the machine, this is not user error.

this is your crown error that is coming up.

Screenshot 2021-09-22 142350

Estlcam has nothing do do with my file.

My file is exported from estlcam. you should be able to download it and run it directly.

My estlcam basics link tells you how to make it yourself.

You are trying to solve too many problems at the same time and confusing me.

The two most pressing issues iun my mind for you right now are

  1. figure out why you can’t run the proven test file directly from your sd card.

  2. learn how to make it yourself so Jamie does not have to make all your files :grin:. Which is step by step at, Estlcam basics

Choose one to work on and I will help you. But not both and repetier, ect.

when i run your file direct it is cutting circles . lets focus on this right now then we will deal with estlcam @vicious1

You don’t need Estlcam to use the crown test file. Just put it as is on the SD card nd run it.

You’ve already been given this information, I’m just repeating it. Again.

Troubleshooting, you want to eliminate as many variables as possible. With the crown test file, you eliminate all of the issues that might be from the CAD and CAM, and are working with just the machine itself, since the CAD and CAM are already done and in a known good working state.

Once you get the crown printing correctly, then we can move back to what’s going on with the rest of the workflow. One thing at a time.

Once you have something that works properly for the machine, then we can look at what’s wrong with the CAM.

If you want to do your drawings in Inkscape, that should be fine, and Etlcam should be able to open them. I suspect that you’ve got something not right with the setup there. The Estlcam basics page should have everything that you need to do to set up Estlcam to work.

Do not use the CNC controller for Estlcam. That assumes that you’re using Estlcam’s firmware, which you should not be. You should be using the V1 firmware.

I test my serial port connectivity with Putty first, if it connects and will accept simple commands, (like M119) then I can proceed with something else. I’ve never used Repetier Host myself though.

The drawing was done in inkscape and transferred to estlcam. I followed all the instructions and I digitized it correct. I have cnc experience which is a plus in situations like this. The problem is on the board.
I just bought a new SD card and guess what ? Same issues. So the card is not the problem .

No it isn’t. You just verified it with Jamie’s gcode.

The issue is file handling somehow. The test crown works and has actually been tested in this thread by me and Barry. You need to figure out what you are doing to corrupt that file before you het it on the SD card.

I’ll so a video of me transferring the file. That will end the confusion
Sorry my bad battery died
This is me uploading the test crown and running it @vicious1