Estlcam & Repetier Host newbie questions?

Hey Everyone,

I finished assembling my MPCNC yesterday and have been trying to work my way through Estlcam & Repteier Host on my way to successful carving & engraving.

I tried following the mini tutorial here and when I loaded the vector image in Estlcam and scaled it all went fine. I saved CNC and then opened it in R-Host. The image was visible but was “hanging” off of the edge of the grid. How do I move it?

I then ran the print and it worked ok. I am having some strangeness with zero & start point but that may be operator headspace.

When I downloaded or created other DXF images and processed them through Estlcam all went well but after the very first image I opened none of them are visible in R-Host. The grid is visible but no image. I have tried various views and zooms to no avail. I would think that in a 2d/2.5d drawing that I would use the “top” view. Is that correct?

They print ok. Still some issues to work through but I am getting a print.

Lastly, in Estlcam I created text for a plaque and it played well with some fonts but when using the fonts that I really wanted it would lock up when I hit the “preview” or “ok” button when finished. Is there a fix/workaround? Or do I need to “test drive” fonts to make sure that they play with Estlcam. Yes, I rebooted my PC and tried with only Estlcam running on Win7 Pro 64bit.




Perhaps there is a different app that I should be using instead of Repetier Host?

Some fonts really freak estlcam out.

Any suggestions as to getting it working?

Should I dump the Repetier software? Is there an app that works?

Boy… I must have pissed off the tech gods…

I thought I might have better success finding answers over at the Repetier forum. I signed up and the bloody thing wants me to answer a confirmation email that I am not receiving… No response from their support folks either.

Anyone need a 3’x4’ doorstop with stainless rails???

I’m def. not an expert in repetier host, but hopefully my similar experiences/fixes help (or at least leads you to the fix).

The image was visible but was “hanging” off of the edge of the grid. How do I move it?
you said it still does the piece ok, to me it sounds like it’s just the visual on host, that can be adjusted by changing the ‘printer shape’ under ‘printer settings’.

none of them are visible in R-Host
This can be an issue with the printer shape as well (esp if host sees the the zero as off the printer shape/grid)
I think when I first set mine up Host was displaying milled objects under the build plate, which made viewing the object hard until view was rotated, I think adjusting the printer shape fixed this for me when I had that issue?

Font issues
as Barry stated earlier Estlcam hates the hell out of some fonts =\
For text designs I’ve been making models/svg’s of the text in a different editor, then import them over to estlcam

  • the text editor in sketchup is pretty easy to use


Thank you VERY MUCH for your reply!!

I will take a look at the printer shape and see what I can come up with.

As to the font issue, for my first attempt at running text I created the design including the text and a border in Inkscape. I saved it as a DXF and opened it in Estlcam. I got the border but no text. I tried it three times with three different designs and never got the text to follow the border to Estlcam. Following that I simply created the border in Inkscape and added the text in Estlcam. Any thoughts on that behavior?

Thank you again.


Hey Bradley,

You are my Hero!!

It took a bit of tinkering but I got it to play nicely by changing the printer shape/size.

Thank you sooo much for the assistance. I am usually a fair hand at working through this kind of thing myself. Not this time…

Thank you again.