ESTLCAM - Z depth and depth per pass problem

Hi everyone,

I am trying to do my first cut out of some plywood after validating that evrything work with some pen drawings.

I am using ESTLCAM and Repetier to do the job. My MPCNC is on standard setup with all recommended hardware from Vicious, Marlin RC7 and 8mm threaded rod.
I have set up ESTLCAM like on the tutorial to comply with Marlin RC7 firmware, Marlin is set up for 1.25mm/revolution on Z axis because of my 8mm threaded rod.
I think i have everything fine BUT… i am facing a problem :slight_smile:

After drawing it with a pen, I try to make the tutorial of the crown but with a 4mm bit and a plywood sheet.

  • I tried a first one asking for 0.5mm engraving: everything went fine except i forgot to measure how deep the engraving result was after the job ended.
  • Happy of that first try i started the same job asking for 3mm engraving depth and my tool was set up to make 1mm depth per pass. If i understand everything okay this should have generate 3 passes of 1mm depth.
    So i hit the start button and the bit directly went to a 3mm depth into the plywood and started to draw !! It took me some seconds to realise that because it seemed to ran okay but i had to cut-off the job because the bit was stressed out (loud noise, vibrations)

I decided to take my caliper and measure the depth of the first engraving and saw a 1.15mm depth instead of the 0.5mm asked and on the second try i had a 3.8mm instead of 3mm and in just one pass when it should have done it in 3 passes…

I checked everything this moring during more than 2 hours : checking the gcode, checking estlacam parameters, checking repetier host, marlin firmware config.h and searching the forum for similar problem…

Could someone help me and point in the right direction to sort this problem out because i obviously made something wrong… but where ??? That’s a mystery to me :frowning:

Thanks for all your help in davnce :wink:

If it’s a problem with your estlcam setup, then you would see it in the gcode moves. Something like:

G01 Z-1.0

Is what you should see. That’s 1mm down, it’s probably going to be on a line without an x or y, and the XY moves will be without a z, unless you are doing helical drilling or something.

Most likely, it’s you z axis steps/mm, or maybe a jumper is missing under your z axis, so it’s doing the wrong stepping. If you just set the z at the spoil board, and then make a move up, say 3mm, you should be able to measure that and confirm that you are close. Really, you shouldn’t need to “calibrate” it, you should calculate it, and it should be right. All three jumpers under the driver board means 32nd stepping, if you have 8th stepping configured, it would be going 4x as far, so that also might be the issue

Also, you can buy some foam from home depot for a few bucks. And you can test out your milling before you break something (like a tool mount).

HI Jeff

In the Gcode i have the good values for the Axis it displays Z-0.5 when i asked for a 0.5mm engraving and Z-3.0 when i asked for 3mm engraving.

But the second problem is also the Z depth per pass, with 3mm asked ishould have got 3 passes of 1mm related to my tool setup… but it did not :frowning:

I am really lost.

move and measure a z move of 10mm, what do you get?

You should confirm that a move of 10mm is actually 10mm, as Ryan said, but if your gcode is also going from the clearance plane z value straight to -3.0, then it’s also an estlcam configuration problem. You can see in the first picture here, that Ryan has the “Z+” value for the tool set to 1.0:

If you change that value, I don’t think it will take effect until you actually create a new toolpath, so if you didn’t start fresh, or delete the path and recreate it, then it might not have taken the change to that setting**. The preview window in estlcam is pretty good at seeing if that worked, because you should be able to look at the preview, and click the up arrow, and see that it’s taking three paths where you asked it to go to 3mm.

** I’m not actually sure that it won’t take effect, but I thought I remember it not doing that for me. I think estlcam assumes you will set up the tools before making any toolpaths.


Hi. How can i ask repetier to move 10mm ? If i push on the up Z arrow in manual control i am not sure that 10 is equal 10mm… am i wrong ?
Or is there a g-code command i can send through repetier ?


About the tool, everything was okay on this side. The chnages were taken into acount so i don’t think it comes from this but more of a unit related thing somewhere.

I am gonna further investigate tonight and keep you informed.
Thanks for your help guys

The up down left right controls are in millimeters, and fractions of millimeters. So hitting up at the 10 ring will move the z up 10 millimeters.


changes in the tool list take effect immediately on any toolpath associated with this tool.
But: obviously not on already created CNC Program files - if you have an existing CNC file and want to change settings you’ll have to save it again.


Hi guys,

I re checked everything from firmware to hardware and found nothing that could explained that.

I reloaded the same gcode, ready to hit the stop button… and this time it worked. Mhheeeeee ! :shocked:

So mysterious !! Sorry for annoying you with this but that gave me directions to follow just in case :wink:

Thanks anyway.