Everything is out of scale

I’ve tried several prints now and every one of the tries to fill my entire cut area. I’ve built a 2’ X 3’ unit and when I print something, it scales up to fill the area.

I made a test file with a part that is supposed to be 350 mm wide. When I try to cut it, it is tried to cut 900 mm wide. I have been careful to make sure all my measurements at in millimeters but I can figure this out. Is there any setting in the marlin firmware that I shave changed?

I’ll using the an Arduino mega, with a ramps 1.4. I’ve added all three jumpers under the drivers for 1/32 steps.

When I generate the NC file, I view it with a CNC viewer (CAMotics) and it appears to be the right size and scale?

What else should I be looking at?


Are you using the firmware that Ryan has provided on this site


Have you setup the steps per mm setting for each axis in the configuration tab of Repeater Host?

Are you using the recommended pullies (16 tooth gt2?)

Good luck and welcome. Hope.you work it out.


I am using the 16 tooth pulleys for the gt2 belts with Nema 17 motor plugged into the RAMPs 1.4 on top of a MEGA.

The firmware is my weakest portion of this project. To my knowledge, I successfully installed the Marlin_16_32_090615. Was there supposed to be changes to that code? I thought it was the Vicious installation version?

Last night I was so frustrated that I was about to order ananotherega and RAMPs board from Vicious but they are out of stock.

Please let me know if this is the expected file and I’lll try flashing it into the Mega again tonight.

Thank you,


That firmware is right. Are you using the DRV8825’s? The a49 drivers do not have 32nd stepping and would do 16th stepping with all three jumpers resulting in double sized things. Is that the issue?

I have a feeling it is a software issue. Follow this , https://www.v1engineering.com/estlcam-basics/, there is a test file at the end to run.

When you figure out the issue, this firmware is better. https://www.v1engineering.com/forum/topic/need-some-beta-testers-for-some-new-firmware-stock-machines-only-please/

But please only change one thing at a time. Until the problem is solved.

So I thought that I had the DRV8825 drivers but I appears that I got the A4988s. Oh, I’m angry!!

I’ve ordered another set of drivers and they will hopefully get here Thursday.

Can you tell me if these drivers could also be why I’ve had stalls and studders when driving the X and Y motors with Repeteir?

I appreciate the help. After the drivers come in and I get them installed, I’ll be happy to try the beta software.


Those drivers are fine just cut the x, y, znd z steps in half in the firmware. They will work just fine.

That would be the reason they weren’t smooth for sure. trying to accelerate 2x’s to fast up to a speed 2x’s too fast!

The correct drivers arrived and have been installed. I did not yet try the newest beta Merlin as I don’t want to make too many changes while I’m still trying to get this perfect.

With the new drivers, everything I was trying to print was cut in half as expected. The problem is that they still are not the correct size. When I have measured everything, I’m still enlarged 125% in both the X and Y direction. This means that when I we printing with the wrong drivers and what ever this issue is, all my cuts were ending up 250% bigger.

Does anybody have another suggestion?

load the beta firmware, and you should be fine if you have all 3 jumpers under the drivers.

I loaded the beta firmware, I made sure my three jumpers are installed. Tried again and still got enlarged print.

I created a simple file with a square, circle and 2 triangles. The square is 80X80, the circle has a diameter of 65. The triangle is inside the triangle which is inside the circle.

When this prints/cuts, the square turns out to be 100X100 and the circle is 80. This means that the scaling is occurring on X and Y.

On one other note, the display didn’t come on. Should I uncomment line 601 of the Configuration.h module?

I greatly appreciate the help.


Richard, what are you using to create your gcode files?

There are 3 different firmware’s sounds like you loaded the wrong one for your screen try the other one.

For you to be scaled that small of an amount you are either doing it in the gcode generation, or you aren’t using 16 tooth pulleys, sounds like you are actually using 20 tooth.

Easy enogh to check. Mark one tooth witha sharpie and give it a count.

I’m using 2 different thinks. ESTLcam which I still haven’t gotten the knack for. I’m also using Easel. In both situations, the cut is scaled up about 125%. I can send you the file and see what you get when you run it.

I know that I’m extremely new to this so before going any further, I dug out all my orders and parts to double check that I’m matching your design.

Arduino MEGA 2560 R3
I’ve upgraded to the new Beta
RAMPS1.4 for RepRap, Mendel, Prusa Came with the A4988 drivers
I’ve upgraded to the DRV8255 drivers
using NEMA 17, 2amp, 84oz, motors
6mm GT2 belt
Pulleys, OOPS. Looks like I goofed this up to. Looks like I got 20 tooth instead of 16.

Guess I figured out why I have a 125% enlargement. Looks like I need to make another order for a set of pulleys.

Thank you for your patience, I’ll be in touch after I get the new pulleys.

On a different note, I used the B16_32_fullG-112515 firmware. I think I need to switch to the B16_32-LCD-112515. I’ll try that and let you know if that works as well.

Is there any setting I could use for the 20 tooth gears until new ones arrive?

Thank you

Yup just change your steps per mm on your x and y axis in the firmware. change to 200 to 160