Extruded stepper making ratcheting noise.

So, I finally got my MP3DP all put together and started testing it today. The X, Y, and Z steppers all run great. The fans both work. I haven’t tested the end stops yet.

My biggest problem is the extruder is making a ratcheting sound (video below). I’m thinking I’ve got the throat too close (as in touching) the pulley but before I take it all apart I was hoping to get some opinions.

Also, my MiniRambo is only reading 1 of the 2 thermocouples. I don’t know which one it is seeing (haven’t tried figuring it out yet) but is there a setting I have to turn on? I’m usinf the LCD and MiniRambo from Ryan.

F34275FF-EA0D-40DB-A726-B3B541F44199.mov (4.79 MB)

A couple of things I can think of to check:

  1. Is the wiring to the extruder right? What happens if you swap the extruder stepper with one of the others? This should tell you if the wiring from the board to the stepper is right. What firmware setting do you have for the stepper current?
  2. It looks like the pulley is contacting the tension spring. Is the tension spring in the right spot? Which pulley are you using?
  3. For the thermistor, do you have the right firmware installed? What is the temperature indication on both thermistors? If you swap the thermistor connections at the miniRambo, you should be able to tell which one is indicating right. If the indications don't change, then you probably have a firmware issue or a board issue. If they do change, then you can try only connecting one at a time to determine which connector/wiring/thermistor to do some more troubleshooting on.
Please note, only change the connections with the miniRambo off.

So, I figured out the problem with the Extruder stepper - it was a bad Stepper Motor! I had another stepper of the same type and tried that one with the same plug configuration and it worked just fine. I swapped out all the extruder components and the new stepper is working the way it should. Even with everything detached, the stepper that came with my MK8 extruder wasn’t working. It seems like it is stuck internally or something. Anyway, that problem is solved, now I’m just trying to figure out if my thermocouples are working properly and how to get the bed to heat up. I think things are probably ok, and it’s just user error since this is my first foray into 3D printing.

At this point, I’m really glad I built my LR2 first! It definitely has helped with figuring out the electronics and the miniRambo board.

1 Like

I also had a case where the stepper’s coils weren’t wired the same as other steppers, and the stepper would only vibrate. You can check with a multimeter which wires form each pair, and switch them to conform to the driver/board connections. (If the connector is standard 2.54 mm pitch “dupont” like connectors, it’s easy to extract and switch the wires into the connector cf. https://youtu.be/eI3fxTH6f6I?t=3m15s)

I took the Stepper apart and you could see where the coils where contacting the inner “bearing”. Seemed like something was off by just a couple of thousands. Strange thing is, when I put it back together, it’s running just fine now… Maybe there was some shmoo in there or something…

Now I just gotta spend time with my temps and heated bed to get them working.