Extruder gear not turning, stutters

Hi all,

After getting correct DRV8825 driver to control the extruder,see following post for detail of my build https://www.v1engineering.com/forum/topic/what-is-this-symptomatic-of-extruder-z-stepper-issue-or-something-else, it will not turn to extrude or retract. I have confirmed that the driver has .6V. When removing the fan, it appears that the gear stutters back and forth rather than turn as expected. I am at a loss as to what may be causing this.

This video, https://youtu.be/tTyAu8GTBFk, is of a manual 10mm extrude attempt followed by a 10mm retraction via Repetier host. As you can see (i hope, quality may be loww), the gear shakes back and forth, it does spin smoothly in a single direction.

I would appreciate any insight as to what I should investigate, I’m at a loss here.

Thank you,


Apologies, I realize now that this should have been in the mp3d printing troubleshooting board. If you would rather I repost this question there, please let me know and I will.

Thank you

Still have 3 jumpers under it? using the right steps in the firmware? can you loosen the tension on the spring or is it all the way loose? Have you tried .7V? double check your wires, one loose one will do that? Does it move if you pinch the tension gear out of the way? Is it up to temp, at least 170C?

I have 3 steppers under driver

Can you elaborate about firmware steps? This may be the issue

Spring tension is already loosened as far as it can

Pinching tension gear also makes no difference

Besides wiggling wires, is there a better way tto check if they are loose?

I have tried .7 and .8V, same problem exists

Temperature is at least 195 or higher

Can you plug in a another stepper to that driver? Then try plugging one into the end of the existing wires. At this point there are too many things it could be we haven’t really narrowed it down at all. I think it is a wiring issue but maybe not.

After additional troubleshooting, I have discovered that this is in fact a wire problem. I replaced my current extruder stepper motor cord with a new one, and the motor began running as expected. Thanks again for the assistance.